kunai 3 L2 issues

adiaz1985adiaz1985 Level 1
edited March 29 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: kunai 3 with rog 5
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence: 99.9 %
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

the L2 uses a magnet switch to trigger button press. i was having issues with L2 tested on gamepad tester in usb and Bluetooth connection. after opening and inspecting the button i found the receiver part of the controller was a bit lose and out of alignment, i realigned while testing in Bluetooth mode. after getting the alignment right i reassembled. when reassembling i noticed the the upper left screw (deep one near L2) acted as a tension screw to tight and the button stopped working

Comments

  • Photos of found issue

  • adiaz1985adiaz1985 Level 1
    edited February 23

    Update: My theory is as the kunai 3 is used the the left thumbstick snags these 3 cables (green, red, blue) to the L2 switch and eventually loosens one or more. I was able to resecure (with soldering iron) the cable however then the green came off this was fixed in the same manner. Button currently working after 2nd repair. I think Asus needs to address the wires somehow (better wires, longer wires, tape down) personally I will be adding a non conductive glue to the ends of these wires so that the wire doesn't come off in the future. This is the 2nd time on 2 different Asus Kunai 3 this has happened to me. Asus has been very helpful with full refunds or option to send in for repair. Luckily I was still in my 30day return window and I have the credit card funds I initiated a return and reordered


    The tension screw theory was wrong. One thing I want to point out is that the L2 started to go bad the first sign was that the L2 button press was effected by the position of the left thumbstick, no other button had any issue

  • ok did the mod. remove left thumbstick and l2 switch. applied small dap of hot glue to the back of the l2 switch. put back the thumbstick first and rerouted the wires over the thumbstick board. reinserted back the l2 switch. working great and wires now out of the thumbstick shrouds way. I observed it hitting the red wire during thumbstick up position, before this quick re routing mod


This discussion has been closed.