AT&T 5G service, missing texts randomly

johnsmith303johnsmith303 Level 1
edited March 10 in ZenFone 8

I purchased the Zenfone 8 about seven months ago. It is on the list of HD voice approved devices for At&t, but not 5g. I didn't know I had to check both before it was too late.

The phone itself is great, I like the size, it's fast, and has a good camera. They have glitches with the adaptive brightness and random volume fluctuation that continue. I have been missing random text messages, in groups but also individual. This is extremely disruptive. Although I get the "VO Lte" icon, I never got the 5g working. I spent at least 10 to 12 hours what technical support between AT&T and ASUS to try and solve the two issues of not recieving random text messages and not getting 5g. We tried everything.

Finally, I read somewhere that putting my SIM in an approved device then back in my phone may work. When I first try this it did not work. I spoke with customer service again and they did not discourage me from doing it but told me that I can do that as a last resort but I should call them with the new device and have them switch the IMEI number before putting Sim back into my Zenfone.

I purchased a refurbished AT&T specific 5G phone on eBay for cheap. I put my Sim in there, called customer service to switch the IMEI. I waited two days and put the same back into my Zenfone, I turned on 5G, and to my surprise it actually works. I got the 5G icon for the first time. I have no idea if it will fix the missing text messages issue but I am hopeful. Hopefully this helps someone in the same boat.

Comments

  • I am also having this issue. In particular I've gotten MMS texts that get split up into multiple and I only receive the last text. On A12

This discussion has been closed.