Kunai 3 Bluetooth cannot be found on my ROG 3

edited February 25 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I have had this persisting issue since Android 11 update and I'm not sure what to do. When I try to pair my Kunai 3 to my ROG 3, it doesn't show up in my available connections on my phone. I tried searching for it on my cousins ipad and it shows up. But for some reason I cannot see it on my phone. I have tried resetting the network settings on my phone, but it's not helped at all. I really need some help to find out why I cannot see my Kunai 3 Bluetooth connection when trying to pair. Please any help would be appreciated. My USB mode is already a failure, always disconnecting and sometimes it doesn't work at all, and I'm resorting to only playing with a cable connected to my phone and controller mode. This is the only way I'm able to use this thing. I'm so disappointed with this and it truly was a waste of money. But I'm trying to get the most out of it since I couldn't return it due to when buying it online, it was the height of covid. So I couldn't get it returned or checked for repairs. Please help me with trying to get the Bluetooth working if possible.

Comments

This discussion has been closed.