Twinview dock kept asking to update

DenverLeeDenverLee Level 1
edited March 6 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: ROG phone 2
  2. Firmware Version:18.0210.2111.190
  3. Rooted or not:no
  4. Frequency of Occurrence: every time
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I have upgraded my firmware recently to latest Android 11 but when I attached twinview dock it kept asking to update evertime. After I proceed update as stated to dock version 7.20 but it never update at all. After a quick check on my phone the dock version still 717. It happens evertime I attach the dock or rebbot my phone with the dock on. Anyone please help. Thanks.

Comments

  • Please tell us some basic information before asking for help:

    1. Model Name: ROG phone 2
    2. Firmware Version:WW_18.0210.2201_0
    3. Rooted or not:no
    4. Frequency of Occurrence: every time
    5. APP Name & APP Version (If your issue relates to the app):

    In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

    ========================================

    Andriod Version 11 -no downgrade before

    (plugs into TwinView Dock 3 -version i dontknow)


    I just bought the Twinview dock 3 ytd (4th Feb 2022) and i have the problem for using Twin View Dock 3, whenever i plug in the dock and connects it, it popsout to force update the dock to version 720, i press "update" (no other options to press), waits for 5~10mins to load and it fails to update everytime.

    Its very frausating T_T that needs to keep force update, waiting to load for a long time and it only shows update fails (after fail update is still usable, works normally)🤨

    Then the next time i plug in to connect again, it happens the same scenario from force update until update fails.


    I tried to search for any solution but i didnt found any solutions on it.

    Does anybody know how to fix this (Force update accessory firmware, waiting for 5~10mins, update fail) problem?

This discussion has been closed.