Thunderbolt driver V1.41.1155.0 is not updated to latest

  1. System: Win 10 21H2
  2. Battery or AC: Both
  3. Model: Zenbook Duo 2021 UX482EG
  4. Frequency of occurrence: Every time I install and reboot it reappears

========================

Detailed description:

The latest drivers in MyAsus shows that Intel Thunderbolt Driver can be updated to V1.41.1155.0

I have downloaded and installed it then restarted the machine but MyAsus says that it is still available for update. Does this mean that the update was not installed or is it that the update was installed and MyAsus does not recognise it?

I have installed other updates and they have not persisted in the same way as this one.



Comments

  • Hi @potatosubwoofer,

    I, has you know, also have the UX482 and I've been there, and the only way I managed to overcome this was:

    1 - Install driver package from ASUS (it will install but it will not update the driver);

    2 - Seek thunderbolt control center in windows apps and uninstall it (you'll install it again don't worry);

    3 - In Device Manager, under System Devices (my Windows is in Portuguese, so I'm not sure it's this name) locate Thunderbolt controller and do the following:

    • Right click;
    • Update controller;
    • Seek controller in computer;
    • Enable choosing from a list of available controllers in your PC (you already install it in step 1);
    • Choose the last version (ver. 1.41.1155.0), the one you downloaded from Asus. If the driver version that you downloaded doesn't appear in means that it wasn't installed and you have to install it correctly;
    • Restart your laptop;
    • Verify again that, now, the version installed for the Thunderbolt is the right one, by going again to device manager, but this time right click thunderbolt, then properties and see in the controller tab that the version is equal to the one you want (it should now be ver. 1.41.1155.0);

    4 - Open Microsoft store and install thunderbolt control center.

    Please, give feedback to know if it worked, and this way perhaps @Blake_ASUS asks Asus proper department to make a walkthrough or changes the update installer.

    Good luck!!

  • Hi there,

    Can you check in Device manager to see if the driver has been installed successfully?

    Thank you.

  • Thanks @MotoWiZ I will take a look at your method and I'm glad it worked for you in the end.

    @Blake_ASUS I have two Thunderbolt drivers that I could find in device manager:


    Thunderbolt Controller - 9A1B : 1.41.1030.0

    Thunderbolt HSA Component: 1.41.1155.0

    If these are not the ones, could you please be a bit more specific about which driver you think I should check?


    Thanks

  • Hi there,

    Thunderbolt HSA Component: 1.41.1155.0 matches the driver version.

    Anyway, please provide the log file in these 2 routes.

    C:\ProgramData\ASUS\ASUS System Control Interface\log

    C:\Users\username\AppData\Local\Packages\B9ECED6F.ASUSPCAssistant_qmba6cd70vzyy\LocalState\log

    Let us check what is causing it to keep showing it.

    Thank you.

  • @Blake_ASUS

    Do you require all of the contents of each log folder?

    I cannot attach *.zip via the forum. Do you have another contact point by which I can send them to you?

  • Just and update: @Blake_ASUS is looking into this issue, apparently there is an error with the driver itself and the next driver might fix the issue

  • Hi @potatosubwoofer,

    Have you tried the solution I pointed. I had the some problem and fixed it that way...

  • @MotoWiZ Sorry I did not try it. I sent the logs to Blake and the team looked through it so that they can patch it next update. It's not urgent really for me - I can live with the notification being there for now. But thanks for the workaround, I will reference your comment if the patch doesn't fix it

Sign In or Register to comment.