ROG Phone 5 Fingerprint sensor fail

edited January 13 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 5
  2. Firmware Version: WW-18.0840.2111.200
  3. Rooted or not: No
  4. Frequency of Occurrence: Suddenly started happening
  5. APP Name & APP Version (If your issue relates to the app): N/A

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

My fingerprint scanner is not working properly. The fingerprint option doesn't show up on lock screen or in security settings. I tried the SMMI_TEST and it says the hardware failed the test.

Comments

  • Forgot to mention I dropped the phone from 4ft high surface and it landed flat on it's rear side. Most likely a hardware issue from the drop. The finger print light works but it doesn't read the fingerprint. It was working fine before the fall. Will a drop cause this to happen to the fingerprint scanner?

  • You have no problem with your Sim card?, If the connector moved with the shock, it should be (Fingerprint and Sim)

  • At first it was both. Once I restarted the phone, the sim worked fine

  • Try restarting in safe mode and testing the sensor for a software cause, if that doesn't work, do the following.


    There is a method that has worked for a few users, you can try it, but if it works, it can start again at slightest shock, not a definitive solution, although I wonder if the service center can provide a real solution.


    You remove the back protection if you have one

    You put a clean cloth or rag on a flat surface

    You put the smartphone on it upside down, screen on the laundry, back on top

    You hold the smartphone well and you massage it at the bottom, from left to right by pressing firmly (at the level of the area that I have surrounded where the connectors are)

    If that doesn't work, don't insist, and visit a service center.


This discussion has been closed.