ROG 5s not recognized in fastboot mode, but ADB works. Windows driver issue?

billfactorbillfactor Level 1
edited January 16 in ROG Phone 5
  1. Model Name: ROG Phone 5s (ZS676KS)
  2. Firmware Version: WW_18.1220.2111.160
  3. Rooted or not: Not until I fix this...
  4. Frequency of Occurrence: Every time

========================================

I received my ROG 5s this week and I've hit a wall trying to root it.

So far, I have been able to unlock the bootloader using Asus' app. My phone displays the unlocked bootloader warning on every boot.

I can't make fastboot work... the "adb reboot bootloader" command does work. I can also boot using the power + volume up button. But the "fastboot devices" command always comes up empty.

I found two possible reasons why fastboot doesn't work. So far I failed to fix either one.

First, the "OEM unlocking" option is missing in my developer options menu. I have the "USB debugging" option checked off. Many of the guides I read online say to allow OEM unlocking. I can't do that.

Second, something's wrong with the fastboot driver on my computer. When get my phone into fastboot mode and plug it into the computer, device manager shows a device called "ASUS_I005D" with an orange caution icon on it. The error message in the properties menu says "The drivers for this device are not installed. (code 28)"

Windows isn't finding a driver with its online driver search.

Does anyone know where I can find the correct driver?


Edit:

I have tried different wires and I am using the side port of the phone and not the bottom port.

This discussion has been closed.