Do not disturb - on beyond scheduled

compass7compass7 Level 1
edited February 4 in ZenFone 8

I have noticed that since the most recent update (5 November 21), that the "Do not disturb" feature does turn on when scheduled (00:00), but does *not* turn off when scheduled (06:00).

I am fairly certain that Do not disturb was scheduling correctly prior to the update, as I have only recently started manually turning it off in the mornings.

It would be good to have this working as expected again.

Comments

  • Same here. Also it does have issues with the power manager setting

  • This is happening on my ZF8 as well, and is getting rather annoying, especially when I miss texts because I didn't look to turn off DND.

  • I'm encountering the same issue.

  • Same here, really annoying. This needs to be fixed quickly.

  • Hi @compass7 @Blumi @troovis @WY5IWYG @camillo.sars

    Check your inbox for a PM from me ;)

  • I found that there are two redundant settings that are in conflict with each other. DND Schedule and Battery Care "Sleep Well" if both are on at the same time the DND schedule doesn't work properly. After disabling DND in "Sleep Well" of Battery Care my normal DND schedule worked as expected again.


  • I recreated the timers and now they seem to work correctly. Apparently the timers showed in the UI but the end-of-silent timer didn't trigger.

  • Except now I seem to have cases where the start trigger doesn't work. I will have to keep an eye on it...

  • @WY5IWYG The duplicate DND setting in the battery section was a surprise. I would never have thought to look in there, in fact for the whole time I have had the phone, I've never drilled into that section at all. Thanks for the insight. I've turned DND off in that section now.

    In fact, a few days ago, I turned off the DND function completely, and the next morning DND was back on even though it was off. Maybe this battery setting was keeping it going, but it did turn off and stay off after I rebooted the phone, so far.

    But now that I have turned off the battery instance, I'll see what happens tonight.

    I may try turning it back on with a schedule, and see how that goes in a day or so.

  • @Irene2_ASUS I saw you message about turning on logging, and did reply about that via email.

    I also mentioned in the email about the issue of the result log size, about 850Mb if I remember correctly from my calculations, of the proposed test most likely exceeding available memory by several times, thus I have not even considered the attempt.

  • Seems like the setting to allow alarms to interrupt the DnD prevents the DnD mode from turning on. If I disable the setting, DnD activates immediately if in the set DnD interval. Weird?

  • It's now just part midnight, and my DND is still off, as specified in the settings. At least that is working :)

    For the next night, I'll re-activate a DND schedule, with Alarm interrupt, as I had in the past, and see if that alarm setting also inhibits DND from turning on in my instance, now that the battery DND is off. And post the result back here.

  • DND turned On and Off as per the schedule.

    That's only the first day of the test, so future iterations will confirm whether it is working properly, or not.

    But now that the Battery DND setting that @WY5IWYG illustrated is off, there is some hope :)

  • So far, the DND schedule is behaving as expected now that the Battery DND setting was disabled.

This discussion has been closed.