ZenBook UM425 USB-C Docking Station lost video after upgrading to windows 11

  1. System: Windows 11
  2. Battery or AC: Both
  3. Model: UM425IA
  4. Frequency of occurrence: Always
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

After upgrading to windows 11 I got a firmware update for Power Delivery from Windows Update. After that upgrade I lost most of the capabilities of my docking station that was working fine before the update. BIOS version is 309 and I reinstalled it. I also tried loading the default config for the BIOS and pressed the shutdown button for 40s. Nothing worked. If I connect the HDMI, I can use a 2nd display.

Comments

  • Hi there,

    Can I have a screenshot of that update in your update history?

    Thank you.

  • Hi Blake, unfortunatelly, I reinstalled Windows 10 in order to check if that solves the problem, but it didn't.

  • Hello Juan,

    If it is a firmware update, it is very likely that what goes wrong already went wrong and can not be revert just by uninstall it or reinstall the system.

    Do you still have the full name and version of the update?

    Thank you.

  • Hi Blake,


    Nope, I lost everything related with the update. Is there any way to reinstall a firmware?. I searched in the Support Page but the only availabe firmware is Audio Dongle FW

  • Hello Juan,

    Please share your product SN in the PM I send you.

    Also, I would like to double confirm with you if only the type C port is not working.

    And if you plug in different type C product other than video or the docking you are using, does it work?

    Thank you.

Sign In or Register to comment.