Rog Phone 3 won't charge with original and any 30w and above charger

YulodaimaYulodaima Level 1
edited December 2021 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Rog Phone 3
  2. Firmware Version: WW_18.0410.2109.172
  3. Rooted or not: No
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): Issue is about not charging

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================


1. happened while i was on a10, and did an update to a11 but still the same and not charging.

2. did a factory reset, still not charging

3. the original charger works on other phones (tested on samsung galaxy s8)

4. bought and used an Anker 30w charger and a new cable, but still not charging

5. asus rog phone 3 can charge if i use a powerbank, or a 10w samsung charger, or other charger that's has weaker than 30w output

6. tested on both ports left and bottom, not charging

7. what i notice is, if i use any 30w charger (even the original), the batter charge lights up and says "Fast Charging", but no charging happens. even if i go to safe mode. it no longer can do "HyperCharge" for some reason. it's like it hates 30w chargers :(

8. fyi i've updated up to the latest, but same banana

9. please help T_T i love this phone but it looks like i'll need to use samsung s8 10w charger just to make it work


Comments

  • Same problem happening with me,on the latest version too.

  • bumping. would like to follow up, need help to fix please :)

  • One thing for sure is the HyperCharge will only work on the official ROG Phone charging brick and won't work with other 30w and above charging brick as the HyperCharge is proprietary. Doesn't matter if the charging brick supports 60w or 100w, it will still be capped at the next available fast charging speed which is Power Delivery at 10w / 12w / 15w (if i am not mistaken, someone please correct me if i am wrong).


    I am on the same firmware and am able to get the HyperCharge speed on my original ROG Phone charging brick and original cable. Did you use a different cable by any chance? Would it be possible for you try on another ROG Phone charging brick? Also is your unit a Tencent unit?

  • Same problem, not charging with original charger, i tried to charge my device rog3 with oneplus charger it's charging, i tried asus charger to charge a another mobile it works fine. @Gustav_ASUS kindly solve this problem.

  • YulodaimaYulodaima Level 1
    edited November 2021

    nope, none of that tencent sht. also i've mentioned that i used the original charger and cable, but still no hypercharge, not even charging at all. and unfortunately i don't have a spare asus rog phone charger.

  • Hi @Yulodaima ,

    Check your inbox for a PM from me ;)

  • pradeep03.pkpradeep03.pk Level 1
    edited November 2021

    Hi @Yulodaima

    charing problem solved? if you got fix, kindly share to me, i also have the same problem. It's so hard to charge my device ROG 3 with some other charger.

    kindly help me. @Yulodaima @Irene2_ASUS

  • I had same problem. I sent logs to devs who said phone's hypercharge controlling ic had died. Phone was under warranty. Took to service center, they replaced motherboard. All under warranty, no charge. If under warranty, take to service center asap

This discussion has been closed.