Disable automatic system updates

In the last 2 OTA system updates I noticed that my choice of not to allow automatic system updates is not respected.

My settings are as follows:

System - System update - Settings - Automatically download and install - Do no allow


What actually happens is to receive notification when a new update is available, asking me to install it now or later. But the later option gives only up to 1 day of delay. After 1 day I receive notification to reboot my device because my update was already installed.

I'm not enrolled in any beta testing programs.

In some situation, for instance if I'm travelling somewhere and my phone works as expected, I prefer to hold the update until I'm back home, not risking to encounter a potential bug breaking a major functionality.

Is there a way to actually stop automatic updates?

Comments

  • izaniizani Level 1

    Yah, a bit annoying, keep bugging me to 'update' while I'm a long journey using Google Maps & Waze. Can't afford to screw up during that time.

  • You cannot turn it off

    Maybe if you try with adb you can do it

  • LianaLiana Level 1

    recently I couldn't reject the update and it bricked my phone... I hate forced updates.

  • I don't want to root my device to resolve this problem because I don't want to void my warranty.

    Why Asus decided to force the users to install the new update when there is a "do not allow" option in settings? It's very sad anti-user practice.

    Will it be fixed in future updates, Asus?

  • FesoFeso Level 1

    Asus, any update on this please?

Sign In or Register to comment.