SIM signal test fail

weijiexu93weijiexu93 Level 1
edited November 28 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_I005DA
  2. Firmware Version: 18.0840.2109.176
  3. Rooted or not: No
  4. Frequency of Occurrence: All the time
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

There was suddenly no sim signal although the phone has detected the sim card. Tried the sim card on other devices and is working perfectly fine. APN has been setup correctly as well. Have tried using both sim trays but doesn't work. Have tried resetting wifi, mobile and Bluetooth and also factory resetting the phone but to no avail. Please help.


Edit: I saw on XDA that pressing the back glass at the bottom of the Rog logo with some force helps and tried doing so myself and true enough, the signal was back for a while. I went on to remove the glass back cover and disconnect and reconnect the btb connectors as well as antennas and it works perfectly fine now.

Comments

This discussion has been closed.