my fingerprint settings missing,air triggers not working, sim card not detected, how i fix it?

Please tell us some basic information before asking for help:

  1. Model Name:rog phone 5
  2. Firmware Version:
  3. Rooted or not:no
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Tagged:

Comments

  • Hi @Dilnayana46 ,

    Are you on the latest firmware 18.0840.2109.176?

    About Sim card not detected, did you have same issue in both slots?

    Regarding fingerprint setting missing, it could be that you turn it off, check the following,

    Go to Settings -> Security & lock screen -> Fingerprint -> Unlock device -> Show/hide option

    For air trigger, Go to settings => Apps => Clear cache and storage of Armory crate and AirTriggers.

    You could also back up your data and perform a factory reset.

    Let me know if your issue persist after all these steps

  • Neel007Neel007 Level 2
    edited October 27

    Asus knows everything about problem. Please give us refund and All the best for your future.

  • I'm also facing the same issue on Asuz 5z. Tried factory data reset, still the issue persist.

    Please let me know how to fix it.

  • Hardware faulty

    Replace your motherboard

  • Hi, i copy/paste te solution worked for me (From XDA forum, problems star with a fall)

    My sim-cards wouldnt be recognized, sometimes only one of them, sometimes both. Additionally, my fingerprint-sensor wasnt working too. By checking pictures of a disassembled phone I could locate the problem inside. It has a connector on the lower end of the phone, which is for sim and FP-sensor. I can definitely and easily come loose.


    Quick and dirty fix for me, was pressing with controlled but quite some force on the lower end of the LED-Rog logo while the phone laying flat on the table. I used my thumb, pushed and restarted the phone to check. Didnt work, pushed a bit harder and restarted again until it worked. The back glass has some flex to it, to make it possible to push the connector back in. Still, be careful to not break it, if you try it yourself.


    When I found that solution, I've sent it in on warranty for proper fixing with this Information to ASUS. They replaced allegedly the mainboard. But I actually think, they just fixed the connector in place, because bending the phone to a certain degree "unfixed" it in my case again. I dont know, if its the same issue you have, but if it is, hope it helps everyone.

Sign In or Register to comment.