Asus screenpad 2.0 not working after update

melvinqueyhmelvinqueyh Level 1
edited November 27 in ZenBook

I just updated to the latest drivers for both Asus screenxpert and Intel graphics driver. The screenpad is on but its acting weirdly. Can't use any of the apps. And even with the mouse pad off or screenpad lock it acts like a main mouse that highlights folders on the desktop.

I reset the computer and the problem still exist.

Tagged:

Comments

  • My screenpad is completely blank/black after the update. Going to try to revert the Intel drivers and maybe the NVIDIA studio drivers.

  • Does reseting the computer itself revert the drivers to factory? Cause I tried doing that and the screen still had the same issue

  • Hi there,

    Which laptop model do you have?

    Can please run the Screenpad Plus Optimizer to see if it adjust it back to work.

    Thank you.

  • UX435E and I ran it before still didn't work

  • Hi there,

    Have you tried this FAQ?

    Please uninstall those drivers first and reboot the device.

    Then install the driver according to the FAQ.

    Thank you.

This discussion has been closed.