Front Camera not Working

iCizzleziCizzlez Level 1
edited December 2021 in ROG Phone 3

I tried to use the front camera today for a meeting but was surprised to see it not working.

I restarted multiple times, booted into safe mode, updated to Android 11, and trying to clear both the cache and storage to no avail.

I'm on the ROG Phone 3

Running version 18.0410.2106.138

The camera app only works after clearing storage. After that, what happens is that when I launch the camera app, the back camera works correctly, but when I try to switch to the front camera, it makes the blur effect but does not switch.

Comments

  • Hi @iCizzlez ,

    Kindly try some troubleshooting tips below:

    1. Does the issue appear right after any apps' download or update?

    2. Does the issue appear on the stock camera only or on other camera apps (e,g. Instagram) as well?

    Please try clearing cache & storage of Camera (long press "Camera">App Info>Storage & memory>Clear cache/Clear storage), then try to re-install 3rd party camera apps and check again.

    3. Also, if that doesnt help I will suggest you to try a to Factory Reset your device. Please note that you should back uo your data otherwise this will delete it.

    Settings>System>Reset options>Erase all data(factory reset)

    4.You can also check on SMMI test:

    Calculator> type ".12345+=">SMMI TEST>Single Test>Wide-angled Camera Capture Test/Tele Camera Capture Test/Front Camera Capture Test

    If any of the SMMI tests fails, indicating high possibility of faulty hardware, kindly bring your device to your nearest ASUS service center for getting your device check: https://www.asus.com/support/Service-Center-All-Countries/

This discussion has been closed.