SHIFT+END and SHIFT+HOME not working in Zenbook S UX393

ekopekop Level 1
edited November 24 in ZenBook
  1. System: Windows 11 Home Single Language (21H2)
  2. Battery or AC: both
  3. Model: Zenbook S UX393 (11th Gen Intel)
  4. Frequency of occurrence: allways
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:When I press Shift + End or Shift + Home in all Windows machine it selects the line till the End or beginning of the line. But it is not in my ASUS laptop

I press Fn key together with Right Arrow to access End


Comments

  • Hi there,

    Can you help to take a closer photo or share a video of the issue?

    Which website or interface are you using the Shift+End on?

    Thank you.

  • ekopekop Level 1

    I tested in Visual Studio Code and Ms. Word office 2019, when I press Shift+End (or Shift+Fn+Right Arow) should be select all text text from cursor to the End of Line. It is working on my Lenovo Flex 5 but in my Asus Zenbook is not working


  • ekopekop Level 1

    When I am working in Visual Studio Code , as shown in the following picture.  

    let say I am at line 380, and cursor is between <div style


    when I press key End (or Fn+Right Arow) the cursor move to the end on line, it is good (working as it is).

    But if I press Shift+End (or Shift+Fn+Right Arow) it should be select all text from cursor to the End of Line, 

    I tested in my Lenovo Flex 5 it is good (working as it is), but why not working with ASUS Zenbook S UX393 (11th Gen Intel).


    Problem also happen for key combination Shift+Home, it should select all text from curson to the begining on Line.


    That is the standard behavior for key combinantion (shift + End and Shift+ Home) in almost text editor in Windows OS. I have experience using that key combination since 1998, using many brand of laptop .

  • Hi there,

    Just double confirming, does this issue happen in Win 10 ?

    Thank you.

  • ekopekop Level 1

    No.. I am using windows 11.

    Let's localize this problem, I'm sure it's not an issue on Win 11 OS, because I tried the same key combination on Lenovo Flex 5 it works fine.Both (Asus & Lenovo) use OS Win 11 which I just installed.

    Please test the key combination on the Zenbook S UX393 which is by your side. (or any series of asus's laptop).

    Tell me whether the key combination works on your test?

    Best Regards,

  • Computer: Asus ZenBook Pro Duo 15 OLED UX582LR

    OS: Windows 11 Pro 21H2 22000.258

    My key combinations for the arrow keys work exactly as expected.

    I tested using Microsoft Visual Studio 2019 and Microsoft Word 365.

  • Hi there,

    Let me check more about it.

    Thank you.

  • Hello ekop,

    we have tried on UX393, UX561... and other model, but on Win10.

    Both Shift +End or Shift+ Home are working. It would select the line that the pointer is pointing at.

    Can you double check if you press FN+ESC, does the FN lock LED lights up or turn off?

    And does other FN key or key combination work?

    Thank you.

  • ekopekop Level 1

    After enabled & disabled the function key Feature (using Fn+Esc) , the probelm is solved.

    Thank You

  • Hello ekop,

    Than you for the update!

This discussion has been closed.