App lock still not working after factory data reset

Hi, my ROG Phone 5's app lock still doesn't work even after doing a factory data reset. I set my app lock to after screen off, but only one app gets locked after I unlock only one app that I set a lock on. Every other apps that I've locked gets automatically unlocked.

Tagged:

Comments

  • @Slurp This is the intended behavior. Change the setting to "Always after use" if you want the system to ask for a new unlock every time you try to open a locked app.

  • What I'm talking about is that I haven't unlocked the other apps yet. For example; I've set a lock on both Google Chrome, and Facebook. I unlock Facebook. I then switch to chrome, but chrome is already unlocked without me unlocking chrome yet. That's the point of setting a lock on each app. You have to unlock them individually, regardless whether you've set the relock to after every use, or after screen off.

  • Hello,

    You can tell me exactly where I find this security setting per application, it interests me a lot but I look for it but I can't find it. Android 11 does not know how to do to my knowledge nor even android 12, is it an Asus application installed with the Rog5?

    Are you talking about this kind of security application or did I misunderstand?

    https://play.google.com/store/apps/details?id=com.privac.tools.applock

  • @Slurp Correct, that's the intended behavior. Unlocking one app will remove the lock for all apps until your chosen method of relocking them kicks in.

    Your solution is to use 'Always after use' in the AppLock settings.

  • @FunBike31

    Long-press an empty space on the home screen -> Preferences -> AppLock

  • Thank you,

    There is other documentation on the Asus interface or the Rog5, I have just reread the 81 pages of the French manual, there is no mention of this security.

    Otherwise, I just enabled it for 3 apps, it works without the bug mentioned on this post. The applications are well locked independently of each other and one application does not unlock the others.

  • Hi, yes! That's what I mean. I'm experiencing this bug right now, where unlocking one app unlocks every other locked app.

  • k_huatk_huat Level 2

    This should not happen, mine works fine with locking or unlocking apps individually or in group. U may need to attach a screen recording video here to show your problem bcoz I guess @Gustav_ASUS misunderstood u with another problem


  • Are you using any third party application?

  • Okay, let me try to explain it once more.

    There are three 'App relock time' settings to choose from under 'Lock behavior' in AppLock settings:

    • Always after use
    • 3 minutes after unlock
    • After screen off

    Of these three, only one (Always after use) will relock all apps when you close/move out of the app you've just unlocked.

    The other two will disable AppLock for all apps when you unlock one app. (And relock them after 3 minutes or when your screen turns off, depending on the setting.)

    This is not a bug, it's the intended behavior of those settings. The system will tell you as much when you choose them.

    @k_huat @Slurp @FunBike31

Sign In or Register to comment.