Restarts gone haywire, charging port high temp warning

anjubunny123anjubunny123 Level 3
edited October 24 in ROG Phone 2

Well my restarts have gone haywire and now my charging port is showing abnormal temps

service center messed up my air triggers , they messed my RGB logo ,both of them dead and not working thanks to pathetic service by asus

I don't actually think service center replaced my MB as well ,

Well I am out of patience ,tired of worrying about what's gonna happen next to my phone

It's time to quit asus for life

Guys don't raise your expectations on sofware updates or A11

Our Phones are dying ,asus knows that too


@ARP_ASUS @Christine_ASUS @Gustav_ASUS @Anders_ASUS

@LP_ASUS @Charles Rollon@CH_ASUS

Think twice before going for asus devices in future

I obviously won't trust asus again

Comments

  • Hi Anuj,

    Sending you a PM once I check it, I have your details.

  • You're gonna tag me to a executive and he's gonna say " you need to pay for the MB and then for the display then we'll help you with the air triggers and RGB logo". Then he'll ask me to visit that sevice center of yours which is not so cool idea considering that expierences I've had

    It's a Never ending cycle of repairs and I don't think my phone can be fixed at its current state that your service guys Turned it into

    I didn't post for help and I don't think you'll be able do anything regarding the mess they made

    I just wanted to create some awareness so that others who bought asus devices like me ,can avoid them in future

This discussion has been closed.