Gmail Auto-Sync randomly turns off

I've searched the forum for any solution to this, and I just don't see anything that applies. I don't play games on my Zenfone 8, and I've turned off all battery optimizations. I do have tasker installed but don't have any profiles or actions set yet. There's really nothing else that I can think of that will turn off Gmail's auto-sync, but every time I turn on Auto-Sync, it works for a while and then is turned off again at random intervals. It's driving me mad. Does anyone know of a cause/solutions?


Software is all up to date, phone is not rooted.

Comments

  • jakislogin2jakislogin2 Level 2
    edited September 2

    The only thing that comes to mind is power saving mode ...

    I can only confirm, that I have 2 Google accounts and both have been syncing since I set them up. No tasker though.

  • @thienman Disable 'Background app management' and make sure Gmail is not prevented in the Auto-start manager.

  • @jakislogin2 Power saving mode is set to turn on at 5% and this happens even when the batter is nowhere near that. But thanks for the suggestion. I'll try uninstalling Tasker, just in case, since it's not being used anyway.

    @Gustav_ASUS Thanks for your suggestion. Background app management is off and Gmail is checked/enabled for Auto-start. Thanks for your reply.

Sign In or Register to comment.