Since upgrading to Android 11 on Rog 3, why is Firefox Browser not working?

ducati9981ducati9981 Level 1
edited September 22 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name:
  2. Firmware Version:
  3. Rooted or not:
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Best Answer

  • ducati9981ducati9981 Level 1
    Accepted Answer

    Well no-one on here came with a solution but I've managed to find one. When you update Android 10 to Android 11 it must mess up system settings, not all but didn't like me installing Firefox and Tik Tok. Solution was to factory reset but backup all your photos etc first before you do this. So not a very good update from Asus, just as bad as Microsoft when it comes to updates. I think I'll move to Xiaomi Black Shark next time as they never have much problems when updating and at least they send automatically not you having to manually do it.

Comments

  • BPMBPM Level 2

    Works fine for me. What's the issue you're having? Saying "it's not working" explains nothing.

  • Yours maybe working but mine is surely not installing as per photograph.

  • BPMBPM Level 2

    So, your issue is that you cannot even install it. I wouldn't say something "isn't working" when you can't even install it in the first place...

    Have you tried checking what the Play Store says is the error?

    And just making sure, but you haven't maxed out the storage on your phone, right?

  • Plenty of room on the phone. Tried clearing cache but still installation problems. Never had the problem on Android 10. Only Android 11.

  • It may be an issue with playstore itself. You can either install the apk via browser or you could just factory reset your phone to avoid all issues.

  • Many thanks but a little too late as I've sorted my own problem out. Cheers anyway.

This discussion has been closed.