ZenBook UM425 Numberpad 2.0 issues

System: Windows 10 Home 21H1 OS build 19043.1165

Model: UM425

I recently bought a ZenBook UM425 and I ran into some issues:

  • The "=" button on the numberpad does not work… or more precisely it is mapped to the "ó" key.
  • If I open the calculator from the numberpad, most of the time it will appear behind other apps, rendering this feature completely useless.

Are these known problems?

Comments

  • Hi ferko,

    Can you help to record a short video of the issue?

    And can you check if the touchpad and numpad driver are the latest one on your device?

    Thank you.

  • @Blake_ASUS as you wish


    I installed the latest drivers but nothing has changed...

  • edited August 16

    Hi ferko,

    May I know which language is the keyboard input set to when the issue happen?

    English or Hungarian? or both?

    I have send you PM to ask for the product SN. Please kindly help to provide.

    Thank you.

  • Windows display language is set to English (United States), my keyboard layout is Hungarian and i use the Hungarian keyboard input option.

    If I switch to US keyboard (in windows settings) then the equal "=" key on the NumberPad works as expected. Calculator still opens behind existing window...

  • Hi ferko,

    Thank you so much for the information.

    So if you open the Calculator app directly from App list, then it would show at the front, right?

  • ferko1276ferko1276 Level 1
    edited August 16

    @Blake_ASUS That’s right.

    I played around with it a little. It seems like it will show up at the back if there is an active window somewhere.

    If I right click on an empty space of the desktop or taskbar (effectively deselecting any active window) before launching the app using the touchpad gesture, then it will appear on top and it will be the new active window. Otherwise it just opens the calculator but it won't be the new "active" app/ window.

  • Hi ferko,

    I see. Thank you for the information.

    I have reported it as well.

  • edited August 20

    Hi Ferko,

    I have share the new numpad driver in the PM.

    Please try it to see if it fix the wrong mapping.

    And for calculator app not showing at the front issue, this is expected.

    The numpad icon is simply opening the app, but detecting which one is the active/main app that show in the front, it would be following Window's detection rule.

    And you have also found the workaround.

    Thank you.

  • @Blake_ASUS The issue persists :(

    "And for calculator app not showing at the front issue, this is expected." - This makes no sense to me but if you say so...

  • ahnafmahnafm Level 1

    I’m not sure but I think this is a Windows issue.

  • I'm not sure either... It only takes 1 function call to launch a built in windows app from a C++ application (from user space) and it works just fine:

    #include <stdlib.h>

    system("calc.exe");

    But it's likely more difficult to do from a driver which might be running in kernel space where the standard library is not even available. I have no idea.

  • Any updates on this?

    This is what I ran into when i tried to find out more about this issue in the documentation. It pretty much states that ~10% of the buttons wont work unless I use an input option that does not match my keyboard layout.

    Seriously?


    I love how the marketing material conveniently fails to mention this little detail. It only mentions OS support in the footnotes...


  • Hello Ferko,

    Sorry I'm confused. I have been waiting for your update about the new driver in the PM.

    There seems to be some issue with the installation. And that the new driver we gave you has been tested many time under Hungarian usage.

    If there is anything we have missed, please let me know.

    Thank you.

Sign In or Register to comment.