Zenfone 8 MMS Issue - Can't download/view images in Messages app

Hi,

I cannot seem to view MMS images in the Messages app on my new Zenfone 8. I checked my APN settings and they all seem correct. I know I have received the MMS as there is a a "Download" button for the message but when I press it nothing happens. Is this a known issue withthe Zenfone 8 and is there a fix or workaround as it is very annoying.

Thanks.

Comments

  • gmjosegmjose Level 1

    I have same issue that I cannot send or receive MMS with pictures attached on Asus Zenfone 8

  • Could you share also your APN settings and the operator you are using?

    Plus share your settings in the Android Messages app?


    (Open Messages, settings)

    Both settings in "Chat Features" and in "Advanced"


    Thanks!

  • gmjosegmjose Level 1

    Using Amaysim on Optus. Have tried to set APN according to amaysim guide.

    There are a number of APNs Optus Internet, Optus Zoo, amaysim mms

  • CideburnsCideburns Level 1

    I have the same issue. I am using ASUS ROG 5

    I put the same SIM in a Samsung galaxy and MMS send and receive fine

    Yet with my SIM in the ROG 5, they fail to send, or I see only a download button when I receive them.

    When I tap the download button, it spins but never downloads

  • I use the default Optus APN settings

    (Not allowed to post a link)

    My Messages app has been granted all permissions.

  • Chat features by Google are disabled.

  • Hey Guys,

    I have exactly the same issue with my ASUS Zenfone 8 with latest OS.

    Troubleshooting Steps Performed so far:

    # Reset Android Stock SMS App Permissions & Allowed full permissions & Reinstalled APP - (No Luck)

    # Reset Network Settings - (No Luck)

    # Reset APN Settings to factory - (No Luck)

    # Added Manual Settings as per Coles Mobile - (No Luck)

    # Tested Other Coles Mobile SIMS - (No Luck)

    # Tested Telstra Postpaid SIMS (Works)

    # Tested my SIM (Coles Mobile on iPhone 11) (Works)

    # Tested other SMS Apps & FB Messenger - (No Luck)


    Carrier: Coles Mobile (AU) MVNO Backend Optus Mobile

    Phone: ASUS Zenfone 8

    Android OS: 11

    Software Version: WW_30.11.51.83

    Coles Mobile Support Advised below MMS Settings (Ething is good except the MMS Protocol (For Android 2.1 or higher): WAP 2.0 which I can't seem to find WPA 2.0)

    Name: Coles Mobile

    Home Page / MMSC: (Ignore the link see screenshot below as I can't post links yet)

    APN: MMS

    Primary / MMS Proxy: 61.88.190.10

    Port: 8070

    MCC: 505

    MNC: 02

    Auth Type: PAP

    APN type: MMS

    MMS Protocol (For Android 2.1 or higher): WAP 2.0


    My Current MMS APN Settings:


  • Would love an answer for this as well. Also having the same issue. No problem with Sim on previous phone (galaxy S9). ZenFone 8 has the download button for the MMS and does not let me send them either. Reset already tried.

  • ZensonZenson Level 1

    Same issue for me too with Zenfone 8 Flip on Exetel which uses the Optus network. Even got a replacement SIM card in addition to all the steps others above have tried. Still no MMS.

  • PaulDRPaulDR Level 1

    I too am having the same issue.

    I also have another sim on the way from Vaya.

  • PaulDRPaulDR Level 1

    So we should all move to telstra supported providers then?

  • RoystoysRoystoys Level 3

    I'd be careful doing that, you may find the same problem

  • ZensonZenson Level 1

    I've tested three. Aldi doesn't work. Belong and Telstra do. Doesn't help much when I'm on Optus though.

  • ravinderkkravinderkk Level 1

    Hey Guys,

    Reached Coles Mobile & as expected I got told get a different phone or speak to ASUS to fix their software. I bet its the APN Settings but can't seem to find a fix ATM

  • gmjosegmjose Level 1

    Hi.

    I have put a boost mobile sim in phone and was able to send receive photos with asus. Put amaysim Optus sim in my samsung s21 and had same issues. Must be in APN settings. Amaysim have not been able to resolve settings.

Sign In or Register to comment.