ASUS ROG G531GD STUCK ASUS LOGO SCREEN, CANT BOOT INTO BIOS AFTER INSTALLING WD SN550 NVME M.2 SSD

Pratik11Pratik11 Level 1
edited August 6 in Others
  1. System: windows
  2. Battery or AC: Both
  3. Model: Asus rog strix G531GD
  4. Frequency of occurrence:
  5. Reset OS: YES
  6. Screenshot or video: NO

========================

Detailed description:I recently bought a new WD sn550 m.2 nvme ssd and whenever i install it in my laptop, it just stuck on asus logo and wont boot to bios and not even to windows.

so, what happened is, I brought the wd sn550 250gb nvme ssd form amazon. as soon as i got it i installed it in my laptop and then it booted to windows , where i allocated it space and then i was going to boot to bios and install a clean win 10 os on the ssd but as soon as i hit the f2 button, my laptop just refuse to go to bios or to windows. then i removed the ssd and then checked and yahh my laptop was working fine as i remove my ssd.

Then i Got over to the internet to find the solution but no luck. almost everyone who brought this ssd and have a asus laptop faceing the exact same problem from over 1 to 1.5 year.

asus should definitely look into this as littrelly everyone is with asus laptop and wd sn550 ssd is faceing the problem.

My bios version is 309.

hoping that someone will help me to get the solution

Thank you in advance.! 🥲🙏

Comments

  • Hi Pratik,

    For changing hardware, we suggest you to send the device to our service center and let our engineer do it for you.

    Thank you.

This discussion has been closed.