UX425EA - Official Asus docking station distorts external monitors' display quality (?)

nadavzhrnadavzhr Level 1
edited July 26 in ZenBook
  1. System: Windows 10 Home
  2. Battery or AC:
  3. Model: ZenBook 14 UX425EA
  4. Frequency of occurrence: Constant
  5. Reset OS:
  6. Screenshot or video: Attached PNG File that explains one assumption of mine regarding the cause of the problem.

=====================

===

Detailed description:

Hello, any help would be much appreciated.

I recently bought a brand new laptop (Model mentioned above), 2 external monitors, and the official ASUS docking station - model HZ-3B (Very disappointed with this purchase so far, this docking station has only caused me problems and headache so far).

I then proceeded to connect everything together, through the docking station ports, and to my unpleasant surprise - when the monitors were connected through the docking station, the display quality was awfully flawed. Taskbar and Desktop icons were pixelated, text paragraphs in Chrome were blurry and my overall graphics were not displayed as they should have been and as they are displayed on my laptop screen.

BUT - When I connected one of the monitors directly to my laptop through the HDMI port, the display quality was flawless.

Moreover, as explained in attached PNG file, the first monitor that was connected directly to the laptop (as written in actual Windows settings) - was connected to the Intel(R) Iris(R) Xe Graphics, and the monitor that was connected through the docking station was not connected to the Iris Graphics but to the "Trigger 6 External Graphics".


I don't claim to declare that this is the cause of the problem but this is my initial assumption based on what I've seen.

I'd appreciate any feedback, help and advice.

Thank you.

This discussion has been closed.