Gps problem

edited August 11 in ROG Phone 2

I am having problems while navigating with google maps on rog 2 after latest update. While navigating my position does not move accurately as it used to be also sometimes does not move at all


  • ronald1985ronald1985 Level 5

    Have a read at the below post to see if anything helps:

    If the above doesn't help and you have dual SIM 4g enabled, turn it off by going to settings - network and internet - SIM cards - turn off dual SIM 4g.

    Also, the above post relates to not locking to satellites.

  • VablemeVableme Level 2

    Apparently you need to calibrate your compass in google maps first. Sometimes it works sometimes don't.

  • Tried all the steps above and still having the same problem. The gps knows my location but does not move in any navigation software like google maps or waze.... Seems that i am staying in my place

  • ronald1985ronald1985 Level 5

    Download GPS Test and then let us know "In View" Satellites and "In Use" Satellites.

  • Here it is after waiting it was no fix

  • ronald1985ronald1985 Level 5

    Cool - you might already have this settings:

    Go to Settings - Location - Google Location Accuracy - ON

    Toggle this, so it is OFF and then ON.

    Also, if you have a case on, take it off and see if it helps get locked sattelites quicker.

  • Already tried this but didnt help. Loosing the fix in gps test while moving also

  • ronald1985ronald1985 Level 5

    Do you have power saving mode on?

    I am trying to find what else you have on where it potentially causes this issue.

  • Noo never. The gps saying no fix now

  • Many people facing same issue here are some

  • ronald1985ronald1985 Level 5

    I have definitely faced this issue before and it was permission related.

    Settings - System - Reset options - Reset app preferences.

    You didn't see you try factory reset but I would give that a try too. After reset, install only the maps app you use and then work your way to other apps to see if there is any culprit.

  • After app pref reset google map sometime is working and somtimes not. Many users are facing same issue after latest update

  • ronald1985ronald1985 Level 5

    Have you tried factory reset and tried only Maps or Waze with nothing else installed.

    At the same time as mentioned above, have you checked your APN settings?

    You only searched for the word GPS in Telegram and they don't all relate to the latest firmware nor about GPS issue. I am in that channel too 🤣

    Anyway, only a few have said this was an issue but no one came back, so I assumed they must of got it to work. Anyway, try the above solutions mentioned in this post and let us know how you get on.

  • FreddetjFreddetj Level 1
    edited July 8

    I can confirm that after the latest update I also suffer from a terrible GPS functionality with no apparent way to fix (tested alot of the recommended tips from all threads)

    Basically my phone has been close to 100% bug free over the last 2 years and BAM, after the .90 update it is completely riddled with bugs.

    * Low volume from mics in apps and video recordings

    * Unusable for video calls since the other person gets echoes = faulty suppression

    * GPS has gone from rock solid to very poor usability.

    And more stuff like 2hrs less sot average than just before updating.

    I have sent bug reports etc.

    Hoping that update arrives soon. 👍

  • Tried everything even a factory reset and that does not solve the problem. As fred said all of this bugs happened after latest update

  • FreddetjFreddetj Level 1

    I now reverted back to A9 and then back up to A10 via FOTA, but stopped at an earlier update (2007.27).

    Everything is working perfectly fine again once back on the older versions...

    Waiting for the fixed update to arrive and be confirmed as good before I update again.

This discussion has been closed.