ROG 5 Framing/Lagging when playing CODM

charlongdoncharlongdon Level 1
edited July 24 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name: ROG 5
  2. Firmware Version: Newest
  3. Rooted or not: Unsure
  4. Frequency of Occurrence: Very frequent
  5. APP Name & APP Version (If your issue relates to the app): CODM

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I purchased a brand new ROG 5 via your website 2 weeks ago, the phone is framing/lagging when I get into gunfights in CODM - I play competitively and it is really disappointing as I was so excited to use this phone.

I keep dropping frames from 55-60 fps to 15-25 fps at random times in the game, it seems to be when I'm screen recording but also has been when I'm not screen recording too.

I have cleared the cache of the screen recorder and the game center even though it is less than 2 weeks old, so there is enough storage. My settings are not using too much CPU, the phone is slightly overheating but I also have the fan which helps. But it is IMPOSSIBLE to play the game competitively when I drop 30 frames 5-10 times a game. Please help!

Tagged:

Comments

  • @charlongdon Some questions for you to answer:

    Have you updated your phone to the latest firmware? (18.0840.2104.56) It was rolled out yesterday, so you might not have gotten a FOTA notice yet.

    Are you using X Mode or any other high-performance scenario profile?

    Are you using the bypass charging feature while playing?

    Are you using any other apps at the same time, e.g. Discord for chatting with your friends?

  • charlongdoncharlongdon Level 1
    edited June 23

    Hi Gustav

    Thanks for the fast reply, I did the update this morning (I'm in the UK).

    I'm using X Mode with the same settings my other comp friends use, who have ROG 5's and ROG 3's.

    I don't play while charging, but if I have to then I use the bypass charging feature.

    I close all other apps, apart from screen recording, when playing the game as this is my secondary device.

    @Gustav_ASUS

  • @charlongdon Have you noticed any difference in performance with the new firmware update?

  • @charlongdon Some more questions for you to answer:

    Do you experience the same drops in frame rate when playing a local match against bots? (Practice vs AI)

    Do you play using mobile network or Wi-Fi? Check if the results are the same for both.

  • @Gustav_ASUS The issue is the same as before the update, it's actually more frequent now than before.

    Yes it's also in matches against bots, the MS of the game is not changing or spiking it's purely just the phone which is dropping frames.

    I play using just Wi-Fi, but I just played a game using mobile data and the issue still happens - it seems to be the device and not the connection.

  • edited June 23

    @charlongdon Thanks. I've tested on two units but I can't seem to be able to get any noticeable drops in frame rate no matter what I do.

    Try clearing the cache of both Armoury Crate, Game Genie and Call of Duty. I don't know if you've tried to reinstall the game, but that's also an option worth trying.

  • I'll attached a clip of the drops for you, thank you for helping - I can only reinstall as a last option as then I'll need to reconfigure my sensitivity and graphics settings and redownload the data packs within the game.

  • @Gustav_ASUS I hope you can see from this clip

  • ronald1985ronald1985 127.0.0.1 Level 5

    What is your ping like? I couldn't see it in the video.

  • @charlongdon Yeah, that doesn't look comfortable.

    Not to be a hassle but can you do another (and longer) screen recording with the Game Genie real-time info widget turned on? That way we can see system temp and FPS while you are playing.

  • No problem, I'll do that in this game as long as I don't die straight away!

  • charlongdoncharlongdon Level 1
    edited June 23

    And my ping was about 20ms, it was stable not spiking @ronald1985

  • @Gustav_ASUS this was just now, cache's are cleared and updates completed

  • This time it literally froze and dropped to 1 frame..

  • @charlongdon Yeah, something is definitely out of whack. 🤔

    I would suggest a full factory reset if you're able to backup any personal data you wish to keep. I understand if you'd rather not though.

    Another option would be to generate a device log for me to pass on to the devs. That way we might be able to figure out if your issue is caused by faulty hardware. (Which I suspect it might be, seeing how you are the only one affected by this.)

    You can also perform the factory reset and get back to me about the device log, should the issue persist through the reset.

  • @charlongdon Were you able to solve your issue?

This discussion has been closed.