TWS sound breaks

vishwa804vishwa804 Level 1
edited August 2021 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Rog 3
  2. Firmware Version:
  3. Rooted or not: not
  4. Frequency of Occurrence: every second
  5. APP Name & APP Version (If your issue relates to the app): All

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


Whenever I play some sound on any app or game, also the in built sound recorder the sound breaks in my TWS. While tws works on other devices. I am using WINGS PHANTOM tws and REALME Earbuds. While on call it works fine.

Please solve this it's so frustrating.



  • Anyone help me resolve this issue.

    edited June 2021

    Hi vishwa804,

    Is the issue only with TWS?

    Have you tried a wired earphones? Does that work correct?

    Also, provide you phone's software version:

    Go to setting => System => About => Software information.

    Share the audio recorder file to check the issue.

  • This issue is with TWS only. Wired earphones work fine.

    Also the sound breaks in the earpiece only, its not like that if I am recording then there will be any splits in the sound.

  • Link loss is frequent. Also it becomes impossible to reconnect with the phone.

  • BPMBPM Level 3

    Can't say I'm experiencing the issue you're having. I currently use the Samsung Galaxy Buds+. Outside of latency issues (Samsung doesn't support any version of AptX for low-latency audio; only their proprietary codec... Wish I knew that before I bought these buds, heh), I haven't had any issues with audio quality or connectivity.

  • @ARP_ASUS have you checked what is the issue causing this?

  • Hi vishwa804,

    Frankly couldn't make out much with recordings. I am using Multiple earphones TWS. Crossbeats for more than 2+ years. ROG Phone 2, 3 and 5. Also, another couple of TWS no disconnection neither any voice lag. TWS are known for latency so slightly can be seen in any TWS ones.

    Possible for you to check with another TWS, can be difficult suggestion but seems more of a compatibility issues.

  • Hi visited a Asus service center,my tws device was working good with another ROG3 at the center. They suggested to flash update the phone manually. This might solve the issue. Please guide me through the process for the same.

  • @vishwa804 Did the say anything more than to "flash update the phone manually"? Unclear if they mean to factory reset the device, however that would be an option. Especially seeing how your earbuds worked fine with another ROG Phone 3 at the service center.

    Before you consider doing that, you can reset your bluetooth settings and see if that solves your issue:

    Settings -> System -> Reset options -> Reset Wi-Fi, mobile & Bluetooth

  • I have already done bluetooth reset, it has no effect. They were saying to use flash tool to load the software.

  • MVMV Level 3

    Realme buds sucks TBH. I too bought them and returned them a day after on flipkart. Then I went onto buying oppo enco, guess what same issue, link loss and losses during playback, returned them as well. At last I got courage to spend some more dime on Soundcore liberty air 2 with aptx hd and haven't touched any buds since then. They work like breeze.

  • vishwa804vishwa804 Level 1
    edited July 2021

    @ARP_ASUS @Gustav_ASUS Done Factory reset still the issue persists. What now?????

  • @ARP_ASUS ?????????

This discussion has been closed.