Some notifications are delayed until the screen is on

frantsyfrantsy Level 1

Some apps' notification are not received when my screen is off. Once I wake up my phone, the messages are then received and shown. It works ok though for apps like WhatsApp, Message, Email.

I've checked all the battery optimization settings for those affected apps but had no clues why they are not working the way they should. These apps are working fine in my other devices.

Also tried to turn off Adaptive Notifcation, still the same.

Appreciate any suggetsions.

Comments

  • The same for me. Notifications arę pretty delayed

  • jfgt7j8qgxjfgt7j8qgx Level 2

    Same problem here. It's quite annoying. Please fix it asap!

  • woody.wwwoody.ww Level 1

    Same issue here. System mode is on "Dynamic", disabled any other battery saving feature.

    I managed to get notifications working on time (and vibrating, which appears to be both a setting in the app and in Android, for this app) for a reminder app. Took a long time to figure it out and several settings to be changed (such as disabling battery optimization for this app...).

    It cannot be normal that one has to do this for every app that send out notifications? Never had an issue with this on my old phones. No "battery optimization" or any other settings and notifications worked like a charm, without battery drain...

  • Timo VosTimo Vos Level 1

    I'm experiencing same issues. Thinking about returning the phone.

  • skynetDEskynetDE Level 1
    edited June 5

    This isn't a hardware issue. Vendors like Samsung have the same issue.

    I'm pretty sure that Asus will take care about it in an update.

  • Timo VosTimo Vos Level 1

    I've Googled a bit. Looks like an Android 11 issue.

    Disabling battery optimalization for a specific app fixes it.

  • jfgt7j8qgxjfgt7j8qgx Level 2

    I don't agree. This issue is not appear on pixel phones.

  • CH_ASUSCH_ASUS admin
    edited June 9

    There is one feature called "Background app management" , which you will find in "Settings -> Battery ; Background App management".


    This turns on hibernation in the background for apps (not killing but sleeping), which may lead to notifications in some apps to be delayed (not outright cancelled).

    You may disable this toggle - which turns the function off.

    OR

    You may choose which apps to not have this function by going into each corresponding app (longpress app icon) , expand the "Advanced" menu , press 'Battery' and then disable "Background app management".


    This may have adverse effects to standby - our suggestion is to turn it off for apps which you care for "on time" notifications, or apps you find are having issues with this.


    For GMAIL / GMS related notifications there seems to have been an issue from Google side (finding lots of similar threads online everywhere cross brands) which should have been addressed recently.

Sign In or Register to comment.