Dual band WiFi totally broken

RoystoysRoystoys Level 4
edited June 26 in ZenFone 7 Series

Since the A11 STABLE UPDATE du

Best Answers

Comments

  • RoystoysRoystoys Level 4
    edited May 24

    I know I actually tried to delete my post because after turning my phone onto flight mode then turning it on again it works, again.

    I am a little embasased now but it doesn't always connect to both bands straight away. It may be my router,I have an Asus RT ac 88 U that's probably about three years old now and the 2.4 GHz radio is not very good anymore. It's slower than it used to be ( sometimes a reboot helps)

    Maybe it's time to go shopping

  • topolovtopolov Level 2
    edited May 24

    I believe it uses MUCH more battery.

    How I came up with that decision. At home I use dual WiFi for more stable connection and it works fine. When I go to work, I'm disabling that feature, because I can't use it in subway. Usage scenario is the same, amount of active screen is the same. Mobile signal strength at home better then at the office. So:

    1. Regular day at home with dual WiFi, by the end of day (21:00) I have ~20%
    2. Regular day at work without dual WFi, by the end of day (21:00) I have ~45%

    I am not complaining, but for me it works like that.

    Wifi at home is Xiaomi Mi Router 4A

    Wifi at the office is Cisco AIR-AP1832I-R-K9

  • eddddedddd Level 2
    edited May 24

    The Wifi in itself never worked 100% for me in any of the firmware versions. the ZF 7 Pro ist the only device at my home network which randomly complains there is no internet on one of my dual band access points and fails to pair with my TV for screen cast until I restart the phone. I tried 4 different ZF and they were all the same.

    If I enable dual band, then really weird stuff starts happening, I quit trying. Disabling dual band sometimes does not go back to normal and just keeps sitting on 5GHz. Now, I don't know if this issue is new in A11, but for me it's new.

  • topolovtopolov Level 2

    Did you try to disable random MAC for you home WiFi, register your ZF at your router and provide dedicated IP for it?

  • RoystoysRoystoys Level 4

    I know what you mean, I remembered why I stopped using as soon as I stated again.

    For me it's hard to get both bands to connect simultaneously at the best of times then when both are connected the phone is either really fast or just seems to get confused and won't load a page at all. I used to put it down to the fact that the router users express VPN,s DNS server but I don't know. I think I'll just turn it off again

  • RoystoysRoystoys Level 4

    No I haven't and to tell the truth I need to Google how to actually set a dedicated IP for my phone but I will play with that and see what I can do. Thanks topolov

  • topolovtopolov Level 2

    You are welcome.

    This may look stupid, because such "smart" devices should work automatically, but sometimes it really helps. I have one office with old Zyxel Keenetic Giga router and only these steps (disable random macs and setup dedicated IPs for client devices) allow users to have stable connection.

  • RoystoysRoystoys Level 4
    edited May 27

    No I don't think it sounds stupid I think it's a brilliant idea. I never would have thought about it but it's a great idea. Especially when the wifi channels are overcrowded Thanks Old friend

This discussion has been closed.