Pocket ghost touches

I'm getting horrible amount of ghost touches while I have my phone in the pocket. Glove mode is off and pocket mode is on. But the sensitivity of proximity sensor is very poor. It detects objects only a few millimeters away from screen.

Is there something that can be done about it? I have newer had this kind of problems. Coming from Galaxy S21 and LG G8s.

Thank you

«1

Comments

  • edited May 26

    Can you please make a video of your device while covering the proximity sensor and trying to press buttons. Both the power button and the screen. Then I will see if your device acts unnatural of if we need to finetune something

  • vavriskavavriska Level 1

    Sensitivity of the sensor when the screen is activated by the button is too low.

  • tv.toreviktv.torevik Level 1

    I'm having the same experience.

  • jfgt7j8qgxjfgt7j8qgx Level 2

    same problem too

  • This issue could be valid. Once I started a conference call with my ear(!!!) pressing the screen, while I was in a call with someone and the phone was all the time next to my face, did not even lowered it down...

  • Please check the PM. Could you run some test for us?

  • I have same issue...

  • pipsss81pipsss81 Level 1

    I also have similar issues. When i have phone in my jeans pocket, i can randomly feel it vibrations as failed fingerprint scan. It sometimes gets locked for to many failed scan attempts and needs pin for screen unlock.

  • ... and also these situations lead to more battery consumption when the phone is in your pocket.

  • poke.ike3poke.ike3 Level 1

    Noticed this issue as well. Sometimes it almost calls emergency services from my pocket :|

    Stranger thing is that sometimes fingerprint reader would not activate, even if the phone is in my hand and sensor is not obstructed

  • Fingerprint unlock is unusable for me because of this, tried with all the settings but nothing fixes it.. Hade to disable fingerprint unlock.

  • Try activating pocket mode in "Advanced" section.

  • MolitroMolitro Level 1

    Same experience here with pocket mode turned on.

    With the phone in the pocket, facing the leg, i can feel the phone vibrating often trying to get a fingerprint read against my leg.

  • vavriskavavriska Level 1

    As I said, I've tried it. It's better when the fingerprint sensor is off. But still a lot of ghost touches when the screen is activated in the pocket.

  • moilanen88moilanen88 Level 1

    Same issue here with pocket mode on :( haven't tried without it tho.

  • CH_ASUSCH_ASUS admin

    Hi

    Try it first without pocket mode. We still use a built in rejection mechanism with "pocket mode" off.

    Perhaps it is better - we're also looking at the sensitivity and implementation logic on pocket mode.


    Thanks!

  • poke.ike3poke.ike3 Level 1
    edited June 8

    From what i've noticed, the sensor does not react as it should (disable tap2wake/fingerprint) when it is obstructed by clothes (textiles). Even with thicker ones.

    If you put your hand on it, it kind of works properly (works every time, but range is very low).

    Same behavior with both pocket mode on or off, so i don't think pocket mode is the issue. More like sensor.

  • MolitroMolitro Level 1

    I tried that, and sure enough it seems that pocket mode "off" works better for avoiding ghost touches.

  • jfgt7j8qgxjfgt7j8qgx Level 2

    pocket mode is not useful

Sign In or Register to comment.