ROG PHONE 3 NOT GETTING CHARGED WITH OFFICIAL CHARGER.

samuelsudeep9samuelsudeep9 Level 1
edited May 22 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name:Rog 3 8gb
  2. Firmware Version:WW-17.0823.2102.143
  3. Rooted or not: not
  4. Frequency of Occurrence:evertime
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Rog Phone 3 not getting charged with Original Charger and Original Cable

1) Its charging with another Type C Usb Charger

2) Noticed the charging was stuck at same point for long time when plugged in.

3) Tried another phone Charger and Cable and it works fine.

4) Tried charging on both side Ports and bottom one and waited for a while but battery not charging.

5) Also did factory reset still issue did not resolved.

6)When you connect original charger and cable, you can see the 2 batter icon on the top and charging animation but it does not charge.

6) Original charger is working on power bank charging.

This discussion has been closed.