Asus ZenBook UX433FN network card problems

omgisthistakenomgisthistaken Level 1
edited May 3 in ZenBook

Since December I have problems with my network card - WiFi doesn't work (and also Bluetooth).

I sent laptop to service for repair, but they gave it back and said it's fine, that it passed diagnostics test and that it was software problem and I need to reinstall windows... So I did, clean Windows 10 install and already at installation Windows warned me that I don't have WiFi so I created offline account. Once I was loged in on fresh installation of Win 10 it was same as before - WiFi didn't work. After that I updated Windows untill there was nothing new and than I downloaded all drivers from asus.com/Laptops/For-Home/ZenBook/ZenBook-14-UX433/HelpDesk_Download/?model2Name=ASUS-ZenBook-14-UX433FN and installed each one of them. The only one which I can't is Asus sync drivers, because I am getting error "Installing driver failed because bluetooth is off or unavailable." and than Error 1722.

When I check my Device manager at Intel Wireless AC 9560 is warning icon and device status says "This device cannot start (Code 10)". And installed drivers are 22.40.0.7 (from 3.3.2021) which are latest.

I am searching for some solutions and I see many people have this problem on this model and there are some solutions like resetting bios to default, which I did but it didn't help - well after 2 restarts WiFi started working but only for couple of minutes than it stopped again. Also a few weeks ago when I installed Windows updates it started working randomly, but only for couple of days.

Is there any permanent solutions for this problem?

This discussion has been closed.