UX581GV keyboard backlight

Can anyone confirm that the keyboard backlight (F7 key) works when in the BIOS setup screen? I'm trying to narrow this down to a missing driver or a hardware issue.

Comments

  • MotoWiZMotoWiZ Level 2

    Hi,

    I've UX482EG, a little different than yours, and in mine the keyboard backlight doesn't work in BIOS setup (it's off in BIOS setup). F7 key has another function in BIOS setup, it doesn't command the keyboard backlight, it's used to navigate in BIOS menu...

    Hope this helps you...

  • Thank you! I'm 99% convinced there is a missing Windows driver/utility that is making this work, and it is not listed on the downloads page. Another thing I've noticed is that the UX581LV is getting frequent driver updates, while the UX581GV is not. The only difference between these two is the LV has a 10th gen CPU.

  • edited March 30

    Right after I typed that, I saw there was an updated ASUS System Control Interface V2. However, the MyASUS app shows that I'm up to date, even though it lists the new driver which I have not yet installed.


  • MotoWiZMotoWiZ Level 2
    edited March 31

    Yesterday MyAsus app and many drivers were updated... Try to update everything and see how it goes. This is the new GUI MyAsus app


  • Thanks! Yup I got all those updates now. Still no working keyboard backlight.

  • MotoWiZMotoWiZ Level 2
    edited April 1

    When you press F7 key, you see splash info on the screen, like the picture?

    Try to press only F7 key, and combination FN+F7 key.

    If you don't see the splash then it's probably a problem of drivers, or of the key itself.

    If you see the splash then it can be a problem of the drivers or the backlight...

    Do the other function keys work and show their splash? For example F1 cuts sound, F2 decreases volume and F3 raises it?

  • edited April 1

    All other function keys show the splash. The F7 key works fine as a function key (I've tested it with a utility program). I've tried F7 and Fn+F7 (locked and unlocked). I've opened the case and confirmed that the backlight ribbon cable is connected properly to the motherboard. This happened after an RMA for a bad battery. I did multiple Windows resets/reinstalls and installed all available ASUS drivers/software manually.

    Several other people have posted in here that this happened to them after an RMA.

    Either the Windows reset is wiping something out, or something is being damaged in the RMA process.

  • MotoWiZMotoWiZ Level 2

    F7 shows the splash? If so then it would be a hardware problem, send it to Asus again for them to repair it.

    If it happened after a RMA then you should complain.

  • F7 does not show the splash.

    I'm not sending it in again. It look a month last time.

  • MotoWiZMotoWiZ Level 2
    edited April 3

    Well, your only other options are to uninstall asus drivers and reinstall them again, namely the ones responsible for the FN Keys.

    Follow this article:

    Nevertheless, I think you'll have the same outcome, if you read the instructions correctly you see that for:

    Fn+F5/F6/F7/F8 -- Monitor brightness/on & off/Toggle Display mode -- Installation of driver & utility is not required

    There's hope in the above procedure though, because it mentions Monitor brightness and display mode for F5~F7 keys, and AFAIK in your case they do different things.

    Other option is to make a brand new installation of windows and drivers...

  • I appreciate your response. None of that has worked however. I have uninstalled/reinstalled drivers (my laptop has ASUS System Control Interface V2) many times.

  • MotoWiZMotoWiZ Level 2

    See this post

    Specially last comment... perhaps this is the solution for you also.

  • Thanks, but the "ATK Package" is not applicable to this laptop. If I understand correctly, ASUS laptops either use the ATK package or the ASUS System Control Interface V2. I've uninstalled/reinstalled this several times. All other hotkeys are working.

Sign In or Register to comment.