WiFi connectivity error on corporate network with Android 11

jockesurfjockesurf Level 1
edited March 19 in ZenFone 6

After the update to Android 11 I can no longer connect to the WiFi at work. The Phone can see the networks and tries to connect but immediately disconnects. Keeps looping around until it finally gives up. My company is running late models of Cisco Access Points with WPA2-Enterprise (no certificate/ do not validate). Also tried a different SSID at work with WPA-Personal security. Same problem as with WPA2-Enterprise.

The Zenfone does not have any problems connecting to my home WiFi (Asus RT-AC2900).

Tried resetting the networks settings. Double checked the identity/password used (works on laptop and other phones/tablets). Tried disabling "Improve Location Accuracy" that seemed to have helped Samsung-users.

According to our network technicians here at work this is a know bug in Android 11. Some vendors have corrected this recently (Samsung etc). Other users with Oneplus and Google Pixel devices have similar problems after recent Android 11 updates.

========================================

  1. Model Name: Zenfone 6 - ZS630KL
  2. Firmware Version: 18.0610.2101.132
  3. Rooted or not: Not rooted (OEM)
  4. Frequency of Occurrence: constant/persistent
  5. APP Name & APP Version (If your issue relates to the app): Built-in WiFi-settings in Android

========================================

Comments

This discussion has been closed.