Turning bluetooth on causes phone to hang. Any apps needing bluetooth cause the same.

Turning on my bluetooth causes the entire system to hang or lag. Sometimes, SystemUI stops working altogether. Usually, I just have to wait and not use any apps until it stays on. Often, after the hang, it turns off again.


Once bluetooth is on, it stays on and is usually okay.


Asus 6Z

Firmware: WW_17.1810.2010.179

Not rooted

Frequency of occurrence: 8/10 times that bluetooth is turned on.

I pair bluetooth with a pair of Signature Acoustics headphones (often) and with a PC (less often). The hang occurs regardless of devices present nearby.

Issue has been present since at least April 2020, when I installed Aarogya Setu (I uninstalled/reinstalled it several times since then)

Comments

  • _jis__jis_ Level 5

    Is it that your problem is triggered by this particular application? If you uninstall it, the problem disappears, and if you reinstall it, the problem reappears? Right?


  • Hi, Please try the troubleshooting tips below:

    1. Please try reset Network: Settings>System>Reset options>Reset Wi-Fi, mobile & Bluetooth

    2. Please try to enter "Safe Mode". If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    https://www.asus.com/support/FAQ/1005163/

    3. Also, please try "the Factory Reset" after backing up all the data.

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

    4. If the issue persists after troubleshooting above, please check your SMMI test: Calculator> type ".12345+=">SMMI TEST>Bluetooth

    If any of the SMMI tests fails, indicating the high possibility of faulty hardware, kindly bring your device to the nearest ASUS repair center for device checking: https://www.asus.com/in/support/Service-Center/India

  • Hi,

    I have already tried resetting the network options but the problem returned. I can't do a factory reset just yet due to all the data on the phone but will try it as option of last resort.

    I ran an SMMI test and none ofthem failed so guess its not a hardware ish.

    Ah, this is possible. I had uninstalled aarogya setu but the problem did persist even then.

    However, I just booted the device in safe mode and it seemed to work fine. However after restarting normally, it seems fine too just slightly slower . I might have to wait a while to see the issue repeat


    I checked what apps access bluetooth location all the time and changed permissions for a few. Let's see if I can identify the culprit.


    Any diagnostic tool that could do the same?

Sign In or Register to comment.