ASUS ROG Strix G531GD stuck at ASUS ROG Logo after inserting WD BLUE SN550 NVMe SSD!!!!!!!!!!!

iashutosh9119iashutosh9119 Level 1
edited February 25 in Others
  1. System: Microsoft Windows 10 Home Single Language
  2. Battery or AC:
  3. Model: ROG Strix G531GD_G531GD
  4. Frequency of occurrence: Always
  5. Reset OS: Yes
  6. Screenshot or video: No

========================

Detailed description:

I have been my laptop since 1.5 years and now yesterday i just bought a WD Blue SN550 M.2 SSD NVMe 500GB (supported as mentioned in the manual)

After this SDD is installed in slot M.2, then I power on this laptop, and it perfectly showed in the windows explorer after creating a volume.

So now i decided to open BIOS and see the SSD so that I can migrate windows on SSD, but stuck on the Asus ROG logo screen. None of the F1-F12-DEL-ESC keys work. Except the power button to turn off the laptop.

The SSD must be removed for my laptop to boot again.

This problem appears everytime and the only solution to boot up again or to open BIOS is to remove the SSD.

After that incident, I did a search on the internet, and found quite a number of cases happened to other people with different laptop models.

I have updated the bios to version 308, which is latest in my case but it didn't solve the problem.


Please provide clear information regarding this issue.

What causes this to happen?

What ways can be done to fix this problem?

For the Asus Support Team, please submit this issue to the relevant team for immediate correction, Because many Asus users find this.


Thank you very much in advance for the answers and support!🙏

Comments

  • Hello iashutosh9119,

    For installing or replacing hardware, and reinstalling OS, please send your device and the hardware part you would like to install to our service center, we will set everything up for you.

    Thank you.

This discussion has been closed.