The new ScreenPad software is buggy

LiviuLiviu Level 2
edited March 2 in ZenBook
  1. System: Windows 10 Pro 10.0.19042
  2. Battery or AC: Both
  3. Model: UX581GV.308
  4. Frequency of occurrence: Always
  5. Reset OS: Yes
  6. Screenshot or video:

========================

Detailed description:

The new Screenpad is a mess. It shows both the expanded version and the button version, overlapping one another.

The expanded version (the vertical menu) gets triggered if you press near it but not on it, so if you click on your apps on the Screenpad, you trigger the Screenpad menu. It's really bad and buggy.

In the bellow picture, if you zoom in, you will se that both menus are triggered and they are overlapping. I've set the menu to be a button, but ScreenPad doesn't care what I set in it's settings.



Comments

  • LiviuLiviu Level 2

    This is another example. Watch in the video where I click with the mouse.


  • LiviuLiviu Level 2
    edited January 22

    Is there a way to switch back to the old version? The new menu is unusable. It switches on its on from button to vertical menu and vice-versa, when I press on an app near to it, it opens the menu, but I have no intention to open it, I just want to press on the app on the screen, or as you see in the picture, I get both the button and the vertical menu and it doesn't matter what I select in the settings, I get both.

    Also, autohide doesn't work.

    This is can't be even called an alpha version.



  • LiviuLiviu Level 2

    This is another example of refusing to stay in button mode and switching to vertical mode even thought in the settings is set to button mode.


  • LiviuLiviu Level 2

    And here is another one. Like really, does anyone test these software before release?



  • I'm glad that I'm not the only one finding the new version super annoying. Most of the time it appears and stays in the foreground when I don't want it, be it the bar or the button... which btw is also much bigger and brighter (meaning much more intrusively annoying!).

    The previous version was almost perfect and didn't need any major facelift....

    Anyway, to solve any visual issues, just toggling the Control Center button setting off and on again will re-initialize the UI for me.

  • The new behavior of the physical Screenpad+ on/off button is also very stupid. Now I need to press it 2 times in order to turn it off. Who even needs to hide instead of disabling it??! The mouse cursor can get lost in there and you'll be wondering where did it go.

  • edited January 28

    Hello Liviu,

    Thank you so much for your feedback. I have tested and reported them all.

    1. Overlapping issue, please kindly turn on the Control Center button and Auto-hide the button for current solution
    2. I'm sorry that it is not possible to downgrade back to the old version
    3. the stay in bar mode issue, the bar will be change back to button after 5-10 second, with or without clicking the Refresh, it's not very instant, may you help to double check?
    4. showing button and bar and the same time issue, it happen only when the screenpad first turn on, but after a while, maybe longer than 10 second, it's back to normal, right ?


  • edited January 28

    Hello uriekael,

    Thank you for your feedback , and I have reported as well.

    For the button and bar is too big, please kindly turn on auto-hide to decrease the inconvenience.

    For hiding the screenpad plus, well....is temporarily cover the screenpad, but it is still working.

    It's design to fit more kind of scenario that we collected from different user feedback.

    Like I put spotify on the screenpad, I play the music, then I want to focus on my work on the main screen, so I hide the screenpad to decrease distraction and the music still can be played.

    (I can even start or stop the music by blind tapping the control bar)

    Hope you can understand. Thank you again.

  • urielkaelurielkael Level 1
    edited January 28

    Program windows can be minimized for the same reason..... and also: support.spotify.com/us/article/keyboard-shortcuts/

    And no, the touch functionality is actually disabled even though the OS still see the display as being attached. At least on my system, not that it matters to me.

    If you want to collect user feedback then make this feature optional to enable / disable for those who actually wants it and all others who doesn't.

    A few days ago, for a moment right after updating something (can't remember if it's MyASUS app or one of the ASUS drivers) it actually went back to the old behavior until the system was restarted.

  • And oh yeah, my issue with the Control Center button/bar is that the auto-hide doesn't work properly just as Liviu also mentioned. It always appears randomly and will stay on top of whatever window that is opened on the Screenpad+ and since the new button is so much bigger than the old one, it makes tapping on what's behind it very difficult.

  • LiviuLiviu Level 2

    For (1), I tried it, and tried any other combination, nothing works, it either display both, or sometimes It actually displays only the button, but once I press on it, it never goes back to being a button, it stays as vertical menu. Autohide doesn't work. It hides it once, but as soon as you move your move on the edge to show the menu, it never hides again after you finish working with it.

    For (3) and (4), I just tested it. It didn't happen. Not only when you turn 2nd monitor on, but that is the most reproducible problem.

    Another annoying thing is that the new screenpad loads after you see the background, it has like 2 seconds delay, whereas on the older version, you would be greeted by the ScreenPad+ animation before you see anything else on the screen. This isn't a big deal, but it takes away the premium feel.

  • LiviuLiviu Level 2

    Another issue that I've found. When I activate the 2nd screen, so from OFF to ON, the sidebar menu appears firstly on the main screen, and then after like 3 seconds it goes on the bottom screen. It's really bad and buggy.

This discussion has been closed.