Kunai 3 right controller not working

seyfert09seyfert09 Level 1
edited February 7 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG Kunai 3
  2. Firmware Version: vff.ff.ff
  3. Rooted or not: no
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app): n/a

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I have bought Kunai 3. It works until it tried to update itself. Now the roght controller does not work and it's firmware is vff.ff.ff. Can somebody help me? I tried to let it connected but it's not updating anymore

Comments

  • I am having a similar issue except my right controller has yet to work at all even when in USB mode on my PC, left controller inputs work but not a single right controller input has worked, the update always fails on the right controller and it displays version Vff.ff.fe

  • I thought many have the same problem. Me too. This problem occurred over than 1 month ago and there's no solution for this. I can't use my kunai again because of this. Sadly the only solution i received from asus is to return it to seller. An expensive item like this come with a problem that annoy a lot of people and come with a frustrating solution also, what a disappointment

  • My gamepad works with the accessorie that goes in in the middle and I use a chord to connect it to the phone but it doesn't work with the case

  • Wow, I've never think of this.. recently i connect kunai with that middle acc and use a cable to directly connected it to phone and it prompted to update firmware. Now my kunai can be used again. Thanks a lot 😀

This discussion has been closed.