Google Maps issues - everything else seems to work fine?!

dgwdgw Level 1
edited January 27 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 3 16GB / 512GB, USA variant (UPC 192876840221)
  2. Firmware Version: 17.0823.2009.99
  3. Rooted or not: Not rooted
  4. Frequency of Occurrence: Daily, often multiple times
  5. APP Name & APP Version (If your issue relates to the app): Google Maps 10.56.1

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Sent here from ROG forum thread 122139 (apparently I'm too new to post a link, even to another ASUS property).

To summarize, this device seems to perform incredibly well except for Google Maps. Most days there is at least one occasion where Maps stops loading place information, directions, or anything else crucial to the function of a navigation app.

It seems unrelated to the phone's network connection, as other features (browser, online games, etc.) work fine even if Maps is refusing to load anything.

Restarting the phone has so far always fixed it. Clearing Maps' cache helped once, but isn't reliable. Uninstalling updates to Maps (which is a system app) also helped once or twice, but is not a reliable workaround. Sometimes it's enough to just bring up Recent Apps and swipe Maps away, then try again. Sometimes turning Airplane Mode on and then off helps.

The only constant is that Maps will stop working almost like clockwork, and nothing fixes it permanently. We have stopped short of trying a factory reset. If desired, I can coax the phone's user (it's not mine; I haven't upgraded yet) into installing the .122 firmware update to see if the "5G connection stability" fixes included there help.

This discussion has been closed.