Strange behaviour with back camera

wolfensilvawolfensilva Level 1
edited January 30 in ZenFone 4 Series

Back camera was working fine even this morning until installed the Adobe Scan app from the Google app store. After uninstalling the app (didn't work as well as I expected vs regular camera) the back camera stopped working on the default pixelmaster app (button to swap just refocus front camera again).

What else I did:

1) other apps that use cameras are able to use it (tried IG, Twitter, Selfie Master) but judging from edge warping on close ups are stuck on the wide lens camera:

I'm not sure which is which, from covering each lens, its the one on the right (or middle, between the left and the flash).

2) cleared cache and app data on all camera apps

3) rebooted, turned off and on again after 30 minutes, in safe mode had same issues.

4) SMMI: flash test crashes it (but flashlight still works independently from the notification area shortcut), wide lens camera returns an error, main camera test shows the front facing camera, front facing camera test works fine

5) tried other camera apps: opencamera and footej also capable of taking photos, with both wide back and frontal camera, but no way of selecting regular camera. FV5 lite has same behaviour as pixelmaster, hitting the change camera button just refocus front camera.

What I still didn't do: backup data and reset to factory (would rather avoid that for time being).

Is there anything else I could do, or did it break?

  1. Model Name: Z01KD
  2. Firmware Version: OPR1.170623.032.WW_Phone -15.0610.1909.39
  3. Rooted or not: no
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app): camera app: 4.0.58.1_190808


Comments

This discussion has been closed.