Wireless Not Working Suddenly with Device Manager having an Exclamation Mark in Network Controller

HifniHifni Level 1
edited January 29 in ZenBook
  1. System: ZenBook UX461FA
  2. Battery or AC: Both
  3. Model: UX461FA
  4. Frequency of occurrence: Permanent from the Event
  5. Reset OS: Windows 10 Pro 64 bit build 19042
  6. Screenshot or video:

========================

Detailed description:

All of a sudden, when I logged into my laptop I noticed that I didn't have WiFi; instead, it was showing a globe mark. When clicked on a globe Mark, It didn't' show the WiFi tab and neither did it show the WiFi Points.

Checked the Device Manager, to see Network Controller had an exclamation mark. Also, I noticed that the Wireless device was not found under the Network Adapter as well. Further, If I opened the Network Controller, I can see additional info saying "Drivers for this device is not installed (Code 28)" and at certain points, I see a "null" value. Refer to the screenshots I attached.

As an alternative, I had a USB Wireless adapter which I am using currently in absence of the inbuilt wireless adapter.

Here is a list what I tried so far:

  1. Rebooted; Nothing happened
  2. Update the driver by Windows Update and then downloaded the Network and Wireless drivers from ASUS and did the update by pointing to the files, But Nothing happened.
  3. Uninstalled the Driver, Disable-Enable the Driver; Nothing happened.
  4. Did a Network Reset; Nothing happened.
  5. Installed the Intel PROSet Wireless Driver from the Intel Site; Nothing happened.

Does this mean that there is a problem with the physical Network


Comments

  • There's an issue with the driver. Unfortunately, bad software is and will always be released for public use and will eventually crash devices. Something broke the network driver. Try to boot on safe mode and see if it works, otherwise, retry some steps that you already done but in this order.

    Disable the driver, uninstall it, reboot without scanning for hardware change, and after reboot, reinstall it via device manager. If it doesn't have a history of the driver locally, download the driver from ASUS support center and install it with administrator privileges.

  • I did log into the device via Safe Mode but still I see the Network controller with an exclamation mark on it in Device Manager. Try to repeat the steps I did earlier but essentially didn't do good at all. Even tried safe mode with Network but it is the same thing.

    By the time of writing, my device's inbuilt Wireless Adapter is still malfunctioning 🥺

  • Backup everything, do a windows reset, if that doesn't help, send it to service.

  • I am having the same problem, I have performed a clean install of windows and the problem persists.

    I learned that my WIFI adapter is soldered to my motherboard, so it's likely not worth sending to service since a motherboard fix would cost quite a bit which could be put toward a new PC.

    I've ordered a usb WIFI card for $20, I'll use that for a while but I know I'll see it every day and that will just deepen my disappointment.

    sigh.


    https://zentalk.asus.com/en/discussion/42389/wifi-adapter-wont-start-code-10

  • Hi Peter, Sorry to heat that. I too consulted a technician at local asus center and he said the same. For me thankfully I am under warranty. However What I am really worried is the consequences after the fix to the device and the workload I have to go through configuring my environment. Everything is working like charm up to now except for the WiFi.😢

  • Hi I am having the exact same issue. Can anyone tell me the cost of this repair if I take it in? Toronto, Canada My warranty expired late October 2020, go figure.

This discussion has been closed.