UNABLE TO ENABLE CAMERA 2 API

Please tell us some basic information before asking for help:

  1. Model Name: ASUS MAX PRO M1
  2. Firmware Version: LEATEST ON PIE
  3. Rooted or not: NOT
  4. Frequency of Occurrence:
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

UNABLE TO ENABLE CAMERA 2API THROUGH COMMAND PROMT BY FASTBOOT MODE.

IT IS NOT EVEN SHOWING DEVICE NUMBER WHILE GIVING COMMAMD "FASTBOOT DEVICES", INSTUD OF THAT IT IS SHOWING "???????" SIGNS.

AFTER PRESSING ENTER, IN MOBLE FASTBOOT MODE IS CLOSING AND ASKING PRESS ANY KEY TO REBOOT DEVICE,

ANY HAVING SOLUTION FOR THIS PROBLEM.

PLEASE TELL ME.

Comments

  • To enable camera2api on stock ROM  


    1) Settingd> System > About Phone > build info : tap multiple times > this will enable developer options. Once activated , go to develop options and enable android usb debugging


    2) boot into fastboot mode (power +vol up)


    2) connect phone to pc via usb and open up command prompt windows in adb folder and give the command : 


    fastboot oem enable_camera_hal3 true


    3) command : fastboot reboot 


    4) install gcam APK and enjoy


    Notes : those who are facing error message "waiting for device'

    Checkpoints :


    1) reinstall max pro m1 device drivers after removing from device manager


    2) in power on mode connect pc to usb and try giving command adb devices , accept pop up if any on phone and then try the fastboot procedure from step 1


    3) sometimes u run out of luck hence try different machines (2 users reported success after they switched machines)


    4) In some cases reported even after showing waiting message users were able to open gcam so even if waiting message shows up , try installing gcam and check whether it opens up. Good luck!

This discussion has been closed.