My ROG 3 Is not charging with original power brick, manual OTA update did not help.

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 3 Strix (ZS661KS)
  2. Firmware Version: 17.0823.2009.99
  3. Rooted or not: NO
  4. Frequency of Occurrence: Allways
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

Okay so i did not update from version 17.0823.2007.58 untill i noticed that my ROG 3 is not charging with original power brick. I tried factory reset and also updated my phone to latest 17.0823.2009.99 version, nothing helped and i still have the same problem. I also tried all the options available in the battery settings but nothing helped.

When i connect the charger to the phone is shows charging icon and two "+" icons on top of it after a while both "+" icons disappear and there is just the lightning icon left but the phone is not charging. (Both "+" and lightning icons are on the battery, not next to it)

I used apple power brick and a different cable to charge and it works but it is way slower as it does not support HyperCharge.

Let me know if there is any solution to this problem, I searched through the discussions with similar issues but found no solution.

Comments

This discussion has been closed.