ROG Phone 3 stopped charging with official charger out of no where.

SwadeshSwadesh Level 1
edited January 7 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: ROG phone 3
  2. Firmware Version: WW_17.0823.2009.99
  3. Rooted or not: No
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

My ROG phone 3 stopped charging with official charger. I can still charge the phone with other chargers and I can charge other phones with official ROG Charger but can't charge ROG 3 with it.

Phone still says that it is hypercharging but nothing happens even if I leave the phone connected for hours.


I tried resetting the phone twice, but it didn't help. I think it is software issue.

I saw the other post where mods sent a fix via pm, and it solved the issue. Can someone help me with that?


I don't know what other information I should provide. Please let me know if you need anything else.

Comments

This discussion has been closed.