Rog Phone 3 stopped charging with company provided charger (no physical damage)

edited January 31 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: rog phone 3
  2. Firmware Version: 17.0823.2009.99
  3. Rooted or not: No
  4. Frequency of Occurrence: constant
  5. APP Name & APP Version (If your issue relates to the app):

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

hi there, here's another frustrating experience from ASUS.


here is the situation:

  1. phone purchased on nov 5
  2. everything working fine until December 2nd
  3. phone not charging using company provided charged from Dec 3rd
  4. tried restarting, didnt work
  5. tried factory reset, didnt work
  6. phone not charging with a spare samsung charger either
  7. but phone charges if i connect to laptop with the company provided type c cord
  8. no information anywhere on the internet on how to resolve (similar discussions were closed on this forum)
  9. call center: totally unaware of this issue and giving very noob advice like switch off/on and/or trying to diagnose the situation without understanding the concern
  10. service center unreachable (bangalore)
  11. unable to return phone because product return window has expired

So basically, after spending more than $750, im stuck with a brick that requires 8 hours to fully charge each time and no support anywhere on the service center, customer care or retailer.

I have never in the past heard of such an issue with any phone (let alone experience it)

Appreciate speedy support on this matter


Regards,

Vasanth

Comments

  • PHPH Level 1

    I feel you man..same here.. wasted

  • @PH wow! so there's no resolution to this? have you tried visiting a service center? what do they say?

  • @vasanthbalachandhran Have you tried with another cable as well?

    I'm sending you a potential fix via PM, but if that does not work I'd like to collect a device log so our engineers can take a closer look.

  • @Gustav_ASUS just some more context before i respond to you.

    Yesterday, later in the day after switching multiple chargers and cords (to figure out the source of the issue), i suddenly noticed the ++ sign on the battery while charging from my laptop. In battery settings it said 'quick charging'. I had no idea what i did differently and I switched back to the original rog 3 charger and it was quick charging (yay!)

    Tried connecting multiple times to the charger during the day to ensure it wasnt a one-off thing and each time i was able to charge. When i woke up in the morning today however, the same issue was back (rog charger not charging the phone). It was mind boggling as i dont know what changed overnight.

    Going through the discussion board on similar topics, I was hoping for Gustav to respond. And he did. And how!

    Gustav - Your solve worked for me. After downloading the apk file and running in the phone switched off. When i rebooted i was (and still am) able to quick charge.

    I feel like this solve should hold but i will swing back in a day or two and update you if it isnt.

    Quick question for you: have you seen instances of where this solve has worked but the issue returns somewhere down the line?


    regards,

    Vasanth

  • @vasanthbalachandhran That's good to hear!

    So far that fix has worked for other users without repeat occurrences of the same issue after running it. But please get back to me in a couple of days and let me know if everything still works!

    Thanks for reaching out! 🙂

  • SwadeshSwadesh Level 1
    edited December 2020

    Can you send me fix as well?

    My phone stopped charging with official charger as well.

    @vasanthbalachandhran @Gustav_ASUS

  • @Gustav_ASUS I bring bad news :(. The issue is back but slightly different from my original situation.

    As I woke up today and plugged in, the battery icon on the phone looked different. It felt like a regular charging icon rather than a hyper charging icon and then suddenly, the phone started to charge and stop, in a fast repeated loop. I disconnected the phone from the rog phone 3 charger and tried charging my phone with my samsung charger and it was working (unlike the first time i reported the issue) but it requires 2 hours to charge from 50-100%. The rog phone 3 charger is still able to charge other devices so, no change there.

    Its just bizzare. Its like whatever fixes it only works for a day and then it comes back in some new avatar.


    Gustav - please let me know what error reports/diagnostics you would like me to send and how :-)

    I'm sooooo convinced you're the only hope i got

  • What did you do first time to fix it?

    My phone doesn't charge with official charger at all.

  • There is an apk file that Gustav sent. Just need to run that. The phone switches off and then was charging alright for a day but now, waiting on Gustav again

  • Can you send me that apk please?

    @vasanthbalachandhran

  • edited December 2020

    im not sure if its ok to do this but here you go. i feel confident this will work for you even though it didnt for me.

    // Attached file removed

  • uxux Level 1

    Hi,

    Similar issue here with a ROG 3, not rooted, Latest firmware.

    I was playing and ignored the battery warning (10% left) as I was about to charge it. I didn't plug it in time, and the phone battery died. Less than a minute after that, I plugged the phone into the charge, but nothing is happening. I have had to safe boot for the phone to start to charge. It wouldn't charge the phone without this manip. If that happens to you, give it a try.

  • @vasanthbalachandhran Sorry to hear that. I will send you instructions on how to log your device. Check your inbox.

  • @Gustav_ASUS could you please send me the fix in private message too ? I have the same problem with my phone shows "+ +" and it doesnt charge


This discussion has been closed.