Asus TUF FX705DT Stutter and lag after update.

gcam83gcam83 Level 1
edited January 19 in Others

Was fine until installed bios update 315. Now games lag and stutter. Same issue that the FX505GT has, which has been happening for over a month.


I've copied the fix here which worked for me until asus fix this.


I hope it will help anyone else having the same issue.

I tried everything including a full system reset and fresh start reinstalling windows, updating drivers, rolling them back, nothing worked apart from this:


(Solution for FX 505 GT lag and performance drop issues.

BIOS downgrading won't fix this problem as it auto updates on every reboot.

Do this thing instead ,

Go to windows search and type -msconfig.

Click enter and go to services and check- hide all microsoft services.

Then disable the following services shown in the pic below and restart the laptop.

Untick these services and click apply and ok.

(Also disable extend battery life in gaming from intel grahics panel)

NOTE:

Armoury crate and My asus wont work after following the above mentioned procedure.

To revert back you just need to enable all those services and restart the laptop.

Till asus fixes this issue this solution works.

https://us.v-cdn.net/6031231/uploads/LNUJ2VAVE28Z/screenshot-5.png

Comments

  • Think my antivirus was the problem.

  • Still same unfortunately

  • gcam83gcam83 Level 1
    edited December 2020

    Okay, what seems to have fixed this for me is uninstalling the latest Nvidia drivers which I downloaded from the Nvidia site, and reinstalling them via the Asus site. I'm thinking maybe the latest drivers from Nvidia aren't tuned for this specific laptop.


    Stick with Asus for getting your drivers from, imo.


    Stutter and lag gone.


    In fact the whole machine now runs quiter, cooler and faster.


    I hope this helps anyone in the same boat.

  • PS. I also did not download the latest bios version after reset. So it's still a very strong possibly that was the issue. If anyone cares. I see at Asus they don't.

  • Looks like asus or windows updated the bios automatically and guess what. Stutter is back. This is a headache I'll never buy another asus again.

  • I have the same problem, but with an asus FX505GM the games lag and the FPS drops drastically, I cannot play games that normally worked well.

    downgrading BIOS dont work and every reboot return at latest BIOS

    its frustraiting becaues mi asus worked fine over a year, and this last 2 months my asus was down performance in games

    During the time I use it, I have given it cleaning maintenance against dust and it has not suffered any shock or overheating


    I hope that asus gives us an answer.....

  • It started happening again once the drivers were updated, I'm glad I'm not alone. Try deactivating windows from updating drivers automatically and then uninstall you're graphics drivers (AMD & Nvidia) via device manager (tick the 'remove all software' box too , then restart your system. This should install its original drivers, the latest ones on the asus site are causing the stutter, the latest ones from nvidia and AMD sites are even worse. Seems to be issues with the newer AMD and Nvidia drivers. The original drivers seem to be better than the newer ones. Asus have gone cold on me regarding this and stopped replying to my emails.

  • gcam83gcam83 Level 1
    edited December 2020

    Theres a few other fixes that may help

  • Also remove geforce experince if you have it, that's causing issues too as it tries to install drivers that are not on the asus website, and plays about with settings that it shouldn't be playing with.

  • gcam83gcam83 Level 1
    edited December 2020

    I've heard the Nvidia audio software also conflicts with the realtech audio drivers but I havent tried removing this yet.

  • I should also mention to set your nvidia graphics setting to 'prefer maximum performance'via the Nvidia setting, only for gta v exe programme.

  • gcam83gcam83 Level 1
    edited December 2020

    Let me know how this works out for you

  • Okay latest update hopefully last! I downloaded DDU uninstaller, completely removed AMD and NVIDIA drivers, reinstalled via asus site, uninstalled geforce experince and NVIDIA audio from add remove programs. Then via nvidia control panel I set gta only to 'max performance' and 'use high performance processor'. So far so good! Touch wood :-)


  • do you think the problem is the nvidia drivers? Although thinking about it, my problem started I think after an update of these drivers, I will use the method you mention to see if the problem is resolved


    thanks

  • No worries hope it helps, I tried the original ones from the asus site after I gave the newer ones another chance (newer ones messed it up again), I used DDU uninstaller so it removed all the old software. the original ones fixed many issues with stuttering. Is it the 60hz screen you have? I'm just wondering if these newer updates are more suited for the 120hz version.

  • Also remember to set gpu to 'prefer max performance' for gta programme only in the nvidia control panel, that aseemed to help clear things up a little too. Cheers, good luck.

  • Also I mean to use the oldest driver version available for your model on the asus site. Unless you do the 'unistall then restart' option which seems to do the same thing. However I noticed DDU seems to do a more thorough clean.

  • It still wasn't 100% fix tho but it did help. I even sold my 60hz asus and bought a 120hz and it's the same so it's not that. Guess asus have just let us down here, I might just return this and go fo different brand tbh.

  • I have similar problem fx505du. I cleaned all amd,nvidia drivers and install again but it is not a solution. I cleaned realtek driver but problem continuing... I downgraded bios 310 and off the windows updates. But PC again update bios in restart. Please help me :)

This discussion has been closed.