Can't adjust screen brightness

turborakettiturboraketti Level 1
edited December 2020 in VivoBook
  1. System: Win 10 Pro
  2. Battery or AC:
  3. Model: Vivobook 14 D413IA
  4. Frequency of occurrence: 100%
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

Since recently I cannot adjust the brightness of the built-in screen anymore. I'm not sure exactly what caused it, but it occurred short after I installed a USB docking station with the Displaylink chipset. Despite removing and uninstalling the docking station, the problem remains.

First the brightness was extremely low and the build-in screen was almost impossible to use. After changing the driver for the internal graphics card from the AMD Radeon to Microsoft Basic Display Adapter, the brightness went up to a usable level (perhaps to max), but I still can't adjust the brightness with F4/F5 keys as I could before.

Any ideas how to get brightness adjustment working again?

Best Answer

  • turborakettiturboraketti Level 1
    Accepted Answer

    It seems the problem is solved. After much experimenting with the drivers and settings for the graphics card, I looked into which driver was installed for the display. This is a bit embarrassing; I discovered that it was not the regular Microsoft Plug'n'Play monitor driver that was installed, but the Teamviewer ditto. I figured that this happened when I, after installing Teamviewer, decided to install the "Show black screen" option. I changed back to Microsoft's Plug'n'Play Monitor and the brightness controls came back! Both the one in the notifications area as well as the keyboard controls.

    Just for the record, this seemed to have nothing to do with the docking station, as I first suspected.

Comments

  • Hello turboraketti,

    May I have a link of introduction of the docking station you use?

    and please kindly check if your BIOS and windows update are all completed.

    And may you enter safe mode to see if there is the same issue?

    Thank you.

  • Thank you @Blake_ASUS for your reply! To your questions:

    • The docking station I use is Andersson LPD 2.0, which is based on the DisplayLink chipset. The manual can be found on manualslib-dot-com (I'm not allowed to post links here). Keep in mind that it is the built-in screen that is the problem, not any screen connected to the dock.
    • The BIOS version is 305 from September this year, which seems to be the latest version. The OS is Windows 10 Pro and is up to date.
    • I tried Safe Mode (with no peripherals connected) but the problem persists -- F4/F5 have no effect, as has any other means of adjusting screen brightness in the OS. Worth mentioning is that the volume controls on adjacent keys work just fine.

    I should also mention that I wiped the computer and installed Win 10 Pro instead of the Home edition that it came with. The brightness controls worked fine after installing Pro, though, so something has happened after that.

    Any suggestions are very welcome!

  • Hello turboraketti,

    would you mind to reset the device again? see if there is an issue after reset.

    and then before doing any other update, install the dock station drivers again.

    Might need to see what action cause the issue.

    Sorry for the inconvenience caused.

    Thank you.

  • brightness cant be adjusted untill installed compatible builtin onboard graphics card driver ,

    say intel dch graphics driver or from amd dch graphics driver .

  • Thank you @Blake_ASUS and @RAJU.MSC.MATHEMATICS for helping!

    I don't want to reset the computer now, as too much setup work is done. I really want to try all other options first.

    Regarding the driver comment that Raju made, the brightness was perfectly adjustable after I installed Win 10 Pro (clean install). At some point of time it ceased to work and one thing I can think of that could be connected is the installation of Displaylink drivers for the docking station, but I'm not sure. I have downloaded the AMD Radeon drivers and installed them, but the issue persists. I also tried to do a screen calibration, as was suggested in some forum thread, but this gives me an error.

    Any other suggestions are welcome!

This discussion has been closed.