xbox ONE controller+USB OTG Problem in M2

RZURZU Level 1
edited December 2020 in ZenFone Max Pro Series

Is it possible to connect an xbox 360 controller using a usb otg cable to an M2 phone? I got the light on the conttoller to blink but nothing else happened. I also tried to plug a mouse and some usb sticks but my phone only gave me pop ups about reverse charging or something. I tried using different otg cables and I also downloaded some apps that detect controller button presses but I got nothing.

  1. Model Name: ZenFone Max Pro M2
  2. Firmware Version: PKQ1.WW Phone-16.2017.2009.097- 20200826
  3. Rooted or not: no
  4. Frequency of Occurrence: always
  5. APP Name & APP Version (If your issue relates to the app): n/a


Comments

  • Hi RZU

    Thank you for your asking. XBOX 360 controller supports some of our OTG supported model. To my knowledge, no additional app is needed, the phone will link with the controller once the two devices plug together with proper cable. Besides, some game apps support this function and some game apps do not.

  • RZURZU Level 1

    Can I get the specific info about M2? Does it actually support connecting to an Xbox 360 controller via a USB OTG cable or no?

    It's weird that even my mouse doesn't do anything other than popping up a "reverse charging" prompt when I connect it to my phone.

  • RZURZU Level 1

    No one else is gonna help me with this? Not even the email I sent to asus support? They just stopped responding.

  • Hi RZU 

    Thank you for your reply. First, please note that the mods on ZenTalk only work on weekdays. Second, for the third-party accessory, I may need your model for further checking. Kindly provide me the model of your Xbox 360 controller. Third, have you ever use the OTG with your MPM2 successfully?

    https://www.asus.com/support/FAQ/1007467/

  • RZURZU Level 1

    Hello and sorry for the misinformation. I have the non-bluetooth version of the Xbox One controller, instead of the 360. I bought it for my PC and I don't have any console.

    And yes, for several times I managed to connect my mouse to my phone using a USB OTG adaptor because I was using VR goggles at the time. So I'm still confused as to why I can't even connect the mouse anymore. Both peripherals are still working just fine on my PC.

  • Hi RZU 

    Thank you for your asking. For XBOX ONE controller, I have forwarded the information to the relevant department. We will keep you updated and your consideration will be very much appreciated.

    For the mouse, please check

    1. Does the OTG cable work with other mouse?

    2. Please try to enter "Safe Mode". If the function works well in Safe Mode yet the issue remains out of Safe Mode, please check on any disturbance from the installed 3rd party apps.

    # How to enter and exit "Safe Mode"

    https://www.asus.com/support/FAQ/1005163/

    3. Also, please try "the Factory Reset" 

    Settings>System>Reset options>Erase all data(factory reset)

    Please note that once the Factory Reset is completed, all data, apps, settings and personal information will be deleted.

  • Hi RZU 

    Have you tried the troubleshooting above? Can the mouse be used again?

    Please perform the Factory Reset first. If the device can use OTG cable with your mouse and VR toggle but can not use with your XBOX ONE controller, then the device does not support your controller model. Sorry for any inconvenience it may be caused. 

  • For usb gamepads you have to recompile kernel with some additional modules, see

    github.com/deveee/android_kernel_asus_sdm660/commit/2a49f7b5a4981d541fe36a3d14af177e010e19a2

    IIRC CONFIG_JOYSTICK_XPAD was for xbox controller.

    Look for some custom roms, maybe someone enabled it by default.

This discussion has been closed.