Hypercharge not functioning properly

PacerPacer Level 1
edited December 2020 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG Phone 2 12/512
  2. Firmware Version: 17.0240.2009.49
  3. Rooted or not: Not / Stock
  4. Frequency of Occurrence: Every single time while charging.
  5. APP Name & APP Version (If your issue relates to the app): N/A

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

1) While HyperCharge status seems to be active, battery goes down instead of up (even while charging when powered off)

2) Whilst in some situations, when the power does go up, it takes 8hrs to charge 8~10% (in theory, charging to 100% may take 80~100hrs / 3 ~ 4 full days, 24hrs non stop charging)

3) While there are no user induced deficiencies, I had concluded that based on my tests above, the battery "may" be deficient (hardware issue) but

4) Having tried out charging while connected to TwinView, HyperCharge works as normal.

TLDR;

ROG2 does not charge while icon n status is on. Both ports don't work (even w/ AAcoolerII) but works if connected to TwinView dock.


Please advise. Thank you.

Comments

  • On a side note, the actual model number/ID is ASUS_I001DC. Sorry for the inaccurate info. Thanks

  • Is there no one that can be of assistance? :(

  • ronald1985ronald1985 127.0.0.1 Level 5

    Have you tried new charger or/and new cable?

    What happens if you turn your phone off and charge? Does it charge?

  • Yes, I have a spare, brand new charger. Both chargers have the same issue. Turning off the phone while charging most of the time, end up discharging instead of charging. But it'll eventually end up charging a few hours later. However, once when docked into twinview dock, it seems to be fine. Though I don't wish to be carrying the dock ask the time just so I can charge my phone. I did do the battery calibration (0% then back to 100%) with no issues.


    Thanks for replying. This problem's driving me nuts. D:

  • *don't wish to be carrying the dock all the time

  • ronald1985ronald1985 127.0.0.1 Level 5

    Does that mean you doing the calibration have worked?

    I am not sure about the twindock because I dont have one, but check to see if the connection is the same as aero cooler. If not the same, it sounds more like hardware.

    The other thing I can think off is the battery care, but you said you charged with the phone off and it still happens, so I dont think that is related.

    It is probably best for you to visit service centre and I appreciate it is not the best time to visit. You can probably wait for someone else to help you while I think what else you can check.

  • Thanks for your reply once again @ronald1985. Very much appreciated. Looking at the situation now, after so many views, expecting a response from others seen kinda low.

    While I dislike lugging around the twinview dock, I am not in a rush to send it for servicing. As for battery calibration, nothing send out of the ordinary, hence I assume it may not be better problem.

    As for the connection between aero cooler n twinview (assuming you mean the charging ports), yes, they are both type c n supports hypercharging. The only difference is that they both run on different firmwares.

  • Sorry about the late reply. This sounds very weird. I will send you a PM so it's easier to investigate this issue

  • Park83Park83 Level 1
    edited November 2020

    I'd like to know if and how this issue resolves.

    I was observing charging issues with the bottom port. I chucked it to a loose connection. Side port charges normally.

    Then we were struck by typhoon Goni so I am charging via generator. I didn't clocked charging speeds for the charger but is was doing its job. Right now, however, it stops at maybe around 12% but the charging icon indicates it is charging. Using charging apps, and despite the hyper charge icon, the current is at negative values.

This discussion has been closed.