Asus A15 FA566IH USB - 3x ports doesnt detect Mobile connection through USB cable.

GOKUL KRISHNAGOKUL KRISHNA Level 1
edited December 2020 in Others
  1. System: Asus A15
  2. Battery or AC: both
  3. Model: FA566IH.311
  4. Frequency of occurrence: Always
  5. Reset OS: Yes
  6. Screenshot or video: Not needed

========================

Detailed description:The issue is, the USB 2 x 3.2 ports(the other 1 x 2.0 USB port works just fine) doesn't detect mobile connection through a USB cable for data transfer and tethering but other functionalities are working like Pendrive detection and good speed with that.


The touchpad suddenly stops working/behaves too slow or doesn't respond for a few seconds and corrects itself later on. Doesn't depend on which application I'm using.


Also, there is a degree of flex on the display while closing and opening the LID around the lower edges of the screen.

This issue is not limited to my device almost everyone on the current BIOS are facing this issue and there's a seperate thread on Reddit but no one from Asus have said anything about that...

Do others in this BIOS version too have the same issue or is it just me?


Thank you in advance!

Comments

  • Hello GOKUL,

    May I know if these issues only happen in BIOS311? or in BIOS309 as well?

    1.USB issue: may I know what kind of external device you connect to? and only data transfer is not working?

    transferring media data or non-media data?

    2.touchpad issue: please kindly check if the touchpad driver has been updated.

    3.display issue: may I have a picture or video of it?


    and does all these issue happened in Safe mode?

    Thank you.

  • GOKUL KRISHNAGOKUL KRISHNA Level 1
    edited November 2020

    I dont remember exactly whether this all started before or after BIOS update but the USB port was working before but not now. Also, from different forums and Q&A sites, it seems that this might be a BIOS issue but not sure if thats the case with my device.


    I have tried different android devices to connect through the usb port. I use the USB connection for Tethering and file transfer options. If you need a specific device name, It's Infinix hot 8 X650C.


    For the touchpad issue, I have updated all the drivers even the windows is up to date to check whether that caused an issue for my device.


    For the Dispaly issue, I contacted a friend of mine who is a technician, He said that the hinge will loosen over time so it's not a big issue for now...

    The Touch pad issue is too annoying to leave it unnoticed even though it occurs for couple of seconds randomly and corrects itself, This ultimately causes so much irritation while scrolling and other things with the touchpad.


    Yes, The issue is persistent in safe mode too.

  • GOKUL KRISHNAGOKUL KRISHNA Level 1
    edited November 2020

    @Blake_ASUS , Any updates on this issue?

    Also please say whether the system firmware is BIOS as in Device manager of Windows.

    If at all this turns out to be a BIOS update related issue, Does rolling back the system firmware through Device manager>system firmware will rollback the BIOS to the previous version?

    I haven't tried anything, since fideling with BIOS may brick my PC ig.

  • I'm pretty sure this is bios 311 problem, my community friend from facebook have problem (USB 3.0 Port) with this bios too. Any update from asus?

  • GOKUL KRISHNAGOKUL KRISHNA Level 1
    edited November 2020

    @novalsofyan Haven't received any updates from Asus or my service engineer who visited my place to diagnose my device.


    Can you please ask your friend whether his issue is resolved. If yes, ask him to list the steps or what he did that helped him to solve the issue?

  • *Update from me:

    I rollback bios to 309 and its normal again. So this is bios 311 problem

  • Dear both,

    I have reported this issue to get more information about it.

    I will keep you updated when there is any update.

    Thank you.

  • Hi @novalsofyan , I guess the BIOS is locked once it's updated to the latest version, It can't be rolled back in the conventional method through the USB stick method. If you could ask your friend how he rolledback the update exactly and list the steps - I can replicate the procedure and try to resolve the issue.


    It would be of great help if you could ask your friend.

  • edited November 2020

    Dear both,

    New BIOS is on the way to solve this issue. I will keep you updated.

    To solve current situation, please downgrade to previous BIOS.

    Sorry for the inconvenience caused.

    Thank you.

  • GOKUL KRISHNAGOKUL KRISHNA Level 1
    edited November 2020

    @Blake_ASUS Please confirm whether the Faulty bios was the reason for touchpad spikes and random moment too?


    Also is there any specific date of release for the next BIOS update?


    Can you please list the procedure to downgrade BIOS? I see that on Asus help page it says that BIOS updates can't be rolled back on any situation.


    I have rolled back the BIOS to the previous version 309 and the USB ports are working fine now.


    Thank you for the Update.


    Please check the Touchpad issue, Ill keep you updated if this new change improves/removes the Touchpad issue.

  • @Blake_ASUS


    The system self updated the BIOS to 311 after a restart, How do I disable the self update so that the BIOS version sticks to 309?


    There was A Warning ⚠ icon in the device manage after I downgraded the BIOS version.

  • Hello GOKUL,

    if that update came from Windows update, you may consider to stop it or 7 days.

    Thank you.

  • Hi @Blake_ASUS ,

    The update is being forced by the Device manager which keeps notifying to perform restart so that system firmware can work fine.

  • Hello GOKUL,

    May you go to this route OS(C:) > Windows > Firmware 

    find out the BIOS311 file and delete it ?

    Thank you.

  • Is the MyAsus app for my model limited with only one Hardware settings options?


    Or should there be more which isn't visible on my version of the app due to some bugs or other things?


    I am on the updated version of the app and the other options weren't available in previous versions too.


    Also My model name isn't correctly shown on the front page of the app, FA566IH.

  • edited November 2020

    Hello GOKUL,

    MyASUS will show the setting that your model support, each model supports different function.

    And Your model is FA506IH in general, the same as FA566IH. Please don't worry about that.

    Thank you.

  • Hello GOKUL,

    BIOS 313 has been released.

    Please kindly check and update.

    Thank you.

This discussion has been closed.